View Full Version : [xubuntu] U10.04 32-bit to X11.04 64-bit - black screen result

August 30th, 2011, 05:02 PM
I see various posts about black screen startup but I'm thinking its because of my initial install mistake that I caused mine so just needing some advice.

Alright, so I did something stupid I think. I had an old AMD machine that had 32-bit 10.04 Ubuntu on it. It was incredibly slow so I got the idea of installing Xubuntu 11.04 – and of course thought I may as well upgrade to 64-bit at the same time. So, I burned the 64-bit xubuntu 11.04 image to a DVD and popped it in the old machine and rebooted.

When asked if I wanted to install alongside, replace, or update the old Ubuntu, I selected update. After it started going, I noticed a message about it deleting the files that were different and I realized it was probably keeping some of the old 32-bit files…but it was too late. After the update was complete, and I let it restart, it came up with a black screen. So, I tried again and this time chose replace – and on the restart after install is complete, I still get a black screen. Well, the black screen is actually a mostly black screen with a thin bluish line at the top like it is attempting and failing to draw the background.

Shouldn’t the remove/replace install have done a disk format to make sure it was starting clean? So I don’t think I should need to get in and do a format from the terminal. But I’m not sure how to recover now from this problem I created. Any suggestions?

Do you think it is related to my initial install of 64 upgrade of a 32 ubuntu or is the installer smart enough to correct my mistake? Just wondering if its something I did or if it is possibly related to other blackscreen issues in the forum.

August 30th, 2011, 05:18 PM

Do you have a 32-bit system or a 64-bit system? If you have a 64-bit system (the hardware) then you can run a 32 bit application on it but you need to have 32-bit libraries. *If you have a 32-bit system(the hardware) you cannot run 64-bit apps on it.

So, is your AMD processor 32-bit or 64--bit?

Once you identify this, then next steps will be addressed.


August 30th, 2011, 05:32 PM
AMD is a 64-bit processor.

August 30th, 2011, 06:06 PM
Did you install the 64-bit server edition or the desktop edition?

The server edition does not have the X window system. Did you back up everything that you wanted saved?

August 30th, 2011, 06:39 PM
Delete all your 32-bit files or headers.

If that doesn't work, do a fresh install.

The black screen thing - when I boot I get a black screen with a flickering cursor for about 20 seconds, and then I get my login pop-up. After that all works fine. Now I have Lucid. Strangely enough, Lucid 64-bit worked fine for me. It wasn't until the third upgrade/update to Lucid that I got the funky screen with the flickering cursor. But as I said, that only lasts for about 20 s.

August 31st, 2011, 12:22 PM
I had 32-bit Lucid on there before and I started going through the motions of the sticky discussion for this and didn't get very far before I decided to try the 64-bit Lucid instead...that worked, its back to basically what it was except 64-bit. So that should give me a little better performance anyhow. Probably going to try and figure it out sometime but for now, its good.

August 31st, 2011, 01:29 PM

August 31st, 2011, 10:26 PM