View Full Version : [SOLVED] Compiz caused desktop to loose everything

August 28th, 2011, 03:11 AM
Hi Ubuntu community, I've been using the latest version of Ubuntu for 2 days now having installed from windows 7 using the wubi installer.

Fiddling with Compiz program to try and get some nice effects for my desktop I've managed to loose everything that is on the desktop. This includes the top bar with the time, battery status etc and also the ability to get at the applications including the terminal. All that's left is the desktop background wallpaper and the mouse cursor. This happens after a reboot.

I can't load the terminal up by Ctrl + Alt + T and if I did I'm not sure what to do next. Can anyone offer some advice on how to recover my desktop.

I don't want to reinstall ubuntu cos I want to learn how to troubleshoot the problems I seem to always create.

I look forward to hearing your advice

Kind regards,

SNIFFY. (Beginner)

Laptop running Ubuntu 11.04: Sony VIAO VGN-CR11Z

(VIAO's don't appear on the HCL for Ubuntu so that might be the first problem, then my knowledge)

August 28th, 2011, 03:20 AM
I haven't used Wubi myself, but from what I hear it can be pretty difficult to get the graphics card drivers working properly. Without the right drivers installed, you're not going to have much luck with Compiz. If you want to play with that stuff, you're much better off dual booting.

August 28th, 2011, 03:25 AM
Ok, that sounds like a good tip. Once I've got the desktop back I will look into removing Compiz. Don't want to dual boot just yet. That's a future project. Thanks for your response.

August 28th, 2011, 03:43 AM
This has actually nothing to do with Wubi, so the header is kinda misleading. And also, you know that your system is well capable to run Unity, as it did this before you fiddled with the Compiz settings.

So, to fix your issue, just follow this troubleshooting guide:

It includes this guide, to enable the Cube, if that's what you tried to do:


August 29th, 2011, 12:04 AM
Hi Krytarik (http://ubuntuforums.org/member.php?u=1187548),

Sorry for placing the header under Wubi and if that caused any confusion. I thought that as I installed it under that, it might be useful.

Many many thanks for your post, you hit the nail right on the head and the links solved my situation and I have unity back up and running. I've never really had that much success with Compiz as I'm not sure I get the graphics card installed correctly. The effects look nice though of what I have seen, so I will keep trying.

Thanks again for your help, I'm very greatful indeed and have learnt a few more things on the way. It's going to be a long road ahead for getting to grips with this operating system and I appreciate the help you have given me.

Kind regards,


Now I've got to work out how to make it say solved.