View Full Version : [ubuntu] Rhythymbox not recognizing CD information (Artist/tracks)

August 26th, 2011, 04:04 PM
As the title states, I just recently installed 11.04. (first time user) and I moved all my .mp3's to rythymbox with no issue. Now, however when I go to place a CD in the drive to rip, or whatever you want to call it, it doesn't recognize the CD.

Let me re-phrase, it recognizes that there is an Audio CD, but it just states "unknown". It still plays, and recognizing the # of tracks, but no information in addition to that. It's just a pain to upload new music and have to manually key all of the artist's information is all.

I apologize if this is potentially in the wrong section, but help is much appreciated. thank you.

Also, the CD's i tried are not Burned cd's they are original, as well as having a perfect internet connection.

I have searched and found similar issues, but not for rythym box, nor were they solved.

I also tried installing banshee with no luck either.

- Jake

Johnny Buffalkill
August 26th, 2011, 11:51 PM
That seems to be a common problem suddenly. I had it happen with quite a few CDs, both in 10.04 and 11.04, and there's another active thread about it both in Rythmbox and Banshee.

What I ended up doing was ripping everything with Asunder and then importing them into Banshee (or you could import them into Rythmbox). There are other stand alone rippers you could also try, but since Asunder worked right away I haven't tried anything else.

Edit: I failed to point out that Asunder found the CD information for every disc I tried so far.

Paul Crawford
August 30th, 2011, 12:14 AM
Having the same problem with 10.04 LTS (but will anyone actually support this?)

Most annoyingly when it tells me it has not recognised the album, and I click on 'submit' the web site, it knows it. Such as this entry:


Now why can't it find them automatically?

How do I automate transferring the stuff it can find on the web site back to Rythembox?

Paul Crawford
October 9th, 2011, 08:35 PM
I think my advice has to be give up and go for windows instead. There is a bug for this logged here:


But as you can see there is no action to fix this *months* after it has been reported. Even MusicBrainz has pointed out the change was coming for TWO YEARS and still no one bothered testing for it:


Really, what is the point in "long term support" when the total amount of support is zero?