View Full Version : [ubuntu] Trouble installing java-jre

August 21st, 2011, 09:07 PM
I type sudo apt-get install sun-java6-jre and hit enter, enter. The license agreement pops up, and then I can't continue. How do I accept it? Clicking Ok won't work, enter won't work. Scrolling to the bottom and then doing either won't work either?

Some help please?

NOTE: The reason I'm trying to install it is to make Minecraft work as it should, I THINK this is the package I need, not sure though.

August 21st, 2011, 09:11 PM
use tab key to go for ok and then press enter

August 21st, 2011, 09:16 PM
You need JDK for MineCraft.

I made a video (click me (http://www.youtube.com/watch?v=DghMR_I31a0)) on what to do. I use 10.04, but the same rules apply for your flavor.

EDIT: Or maybe you could have Java JRE also. I'm not sure. But watch the video and follow my steps and it should work.

August 21st, 2011, 11:55 PM
Well it actually works for me with OpenJDK(or something) aswell but its really slow. And pressing the TAB button worked, stupid not to try it at first, thank you.

BTW I'm trying to shove in optifog in my minecraft.jar but I can't find the .minecraft folder, used the install script to install it. Where is it? Someone told me its in ~/Home/User but there's nothing there.

Don't really understand why you would need the JDK. Runtime environment should be enough I think.

And my last question :) It says in minecraft.net that you should launch it with: java -Xmx1024M -Xms512M -cp Minecraft.jar net.minecraft.LauncherFrame if I run into to out of memory errors. How do you launch the game with that command line?

August 22nd, 2011, 12:26 AM
Okay so I looked up how to show hidden files(stupid...) and have located my minecraft.jar, however. Looking at youtube videos on installing mods in ubuntu they all have the usual(windows) minecraft.jar. In mine the folders and classes are very different.