View Full Version : [SOLVED] Reinstalled Windows 7 and can't load grub

August 21st, 2011, 05:49 AM
I just finished my Windows 7 reinstall, and I go to reboot into Linux, and there's not grub loader. I go into a live CD and get into the grub prompt. Here's what I got:

sudo grub
grub> root (hd0,0)

grub> setup (hd0)

Error 17: Cannot mound selected partition
As for additional information, my fstab is listed below:

aufs / aufs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda6 swap swap defaults 0 0

August 21st, 2011, 06:17 AM
I had the same problem, I then reinstalled Ubuntu and it fixed my Grub where I was able to boot into Ubuntu and Windows.

I loaded Startup Manager so I could change the boot order on Grub.

August 21st, 2011, 06:30 AM
Or I could just look at this link
Fixed it all first try.

August 23rd, 2011, 03:15 PM
Hello, happy to see that Boot-Repair helped. It is a new tool, so if you have 5 minutes, please help translating it in your language : https://translations.launchpad.net/boot-repair/trunk


August 27th, 2011, 04:02 AM
I tried that tool and it didn't work. I ran it through the 3 levels and all failed. Seemed like Grub wanted to boot into a version of Ubuntu not on the hard drive.

I just ended up running Ubuntu 11.04 install again, and Grub was fixed and I was back to having it boot into Windows 7 as my first choice. I think Ubuntu has come improved on itself over the older versions. I started using Ubuntu 7.04. You can't beat it for it being a free OS. If it wasn't for the lack of support for Netflix and iTunes I say it would be a full replacement of Windows. I am still am a fan of Windows. I am running Windows XP on my really old laptop. I had Ubuntu on it too. It ran well with all versions including Ubuntu 11.04. I just found some issues where I had to keep putting my password in to access the wireless connection on my laptop. I like using Ubuntu, but I still have to run Windows to use my Netflix and iTunes to sink up my iPhone.