View Full Version : Star trek online in wine

August 20th, 2011, 06:42 PM
I've been trying for about a week now to get Star Trek Online working in wine and so far no luck. I got the Login screen to load but once i sign in it won't go beyond the load screen.

I'm using Wine 1.3.26 and Ubuntu 10.10.

I've followed several guides and so far none have gotten any better results than another.

I've added a Direct 3D key, installed winetricks, installed IE7. Can anyone help?

August 22nd, 2011, 03:56 PM
No one has any ideas or experience with this?

August 26th, 2011, 09:26 PM
Still no luck getting it to run. Does anyone on the forums have experience with running this game in wine? Would really appreciate some assistance in getting it to run.

August 27th, 2011, 04:37 PM
I run this game. As I recall, I installed IE6 as instructed, but it still didn't work, I needed to install IE8 as well. Never tried IE7. But it sounds like your problem is related to that, because I had the exact same problem, and only after install IE8 did it start working.

Also, I have to use wine 1.3.24 because of a change in the way sound is handled in 1.3.25 and above. I'm still trying find a solution to the sound in later the versions of wine.

August 31st, 2011, 03:50 AM
Thanks. I'll try that ASAP. I'll post the results as soon as I do. Other than the sound problem does everything else function well? No other bugs I should know about?

August 31st, 2011, 04:24 PM
No luck, IE8 keeps crashing on install.

August 31st, 2011, 09:53 PM
Yes, everything works. I used Playonlinux http://www.playonlinux.com/en/

And this helpful article: http://www.redshirtlinux.com/?p=122

Watch the video.

Also, you can try deleting the original preferences detected on setup:

...../Program\ Files/Cryptic\ Studios/localdata/GamePrefs.pref


...../Program\ Files/Cryptic\ Studios/Star\ Trek\ Online/Live/localdata/Gameprefs.Pref

Then re-run the game. It will detect everything again.

September 2nd, 2011, 12:51 AM
Another note, make sure you can access the internet with the IE you installed in wine. Because, if that's failing, you have some other problem.

September 4th, 2011, 06:57 PM
For some reason I cannot get IE8 to install. It say "This program has encountered an error and needs to close." I can't get it to fully install.

September 6th, 2011, 03:10 AM
Did you try from a fresh prefix in playonlinux? And even so, maybe that's all that's needed. if it installed some files, then install IE6 and go from there. The game only needs the mshtml libs from IE to run.

September 18th, 2011, 01:39 PM
More information, I found this thread at the STO forums. Very succinct and it describes pretty much what I did, except I used Playonlinux and, as I said before, the latest version of wine causes no sound, so I have to use 1.3.24


Good luck!