PDA

View Full Version : [ubuntu] lost network connection



ihartmydoghead
August 16th, 2011, 06:56 AM
I have been on Ubuntu for a week or so, and tonight, I cannot get a network connection. I have rebooted my router several times but no luck. {I am currently on my GF's computer, on the same network, so obviously the network and ISP is working, but my computer (Ubuntu 11.04) does not see the network. Help !

dineshs
August 16th, 2011, 07:11 AM
Please open a terminal (applications-accessories-terminal) on ubuntu computer and post the result of
sudo lshw -C network

ihartmydoghead
August 16th, 2011, 07:20 AM
Please open a terminal (applications-accessories-terminal) on ubuntu computer and post the result of
sudo lshw -C network

will do - hold on a minute

ihartmydoghead
August 16th, 2011, 07:24 AM
ok found terminal

HermanAB
August 16th, 2011, 07:26 AM
Well, rebooting is not efficient.

Some tips:
See what is wrong with 'ifconfig' and 'route'.
Restart the network connection by simply replugging the cable.
Restart the DHCP process with 'dhclient eth0'

ihartmydoghead
August 16th, 2011, 07:35 AM
will do - hold on a minute

it asked me for my password
i entered it
it said "network disabled"

ofnuts
August 16th, 2011, 08:09 AM
it asked me for my password
i entered it
it said "network disabled"
In /var/lib/NetworkManager/NetworkManager.state: check if it says

NetworkingEnabled=false

or

NetworkingEnabled=false

If it says "false":

sudo rm /var/lib/NetworkManager/NetworkManager.state
sudo service network-manager restart

(yes, you can erase it, it is recreated automatically)

You may have to manually kick networking back on with commands like `sudo ifconfig eth0 up` (where eth0 is your network interface) and `sudo dhclient`.

Side note: if this is indeed the problem, it also happened to me after the 1st install of Ubuntu. Despite the fix above, it came back several times during my first weeks of use (just had to rerun the commands) and then eventually the problem vanished.

dineshs
August 16th, 2011, 08:13 AM
it asked me for my password
i entered it
it said "network disabled"
Please click on the Network Manager icon on top right of the panel.Ensure that enable networking is ticked.

ihartmydoghead
August 16th, 2011, 08:04 PM
(totally unfamiliar with command line and terminal)
OK, I got to var/lib/NetworkManager$ but cannot get to ".state"
var/lib/NetworkManager$ <---major learning curve to get to here

ofnuts
August 16th, 2011, 08:39 PM
(totally unfamiliar with command line and terminal)
OK, I got to var/lib/NetworkManager$ but cannot get to ".state"
var/lib/NetworkManager$ <---major learning curve to get to here
issue the command:


cat /var/lib/NetworkManager/NetworkManager.statein any terminal. Should type out on terminal something like:

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
(of course, your may say "false")

ihartmydoghead
August 16th, 2011, 08:44 PM
OK, it says "No such file or directory"

ofnuts
August 16th, 2011, 09:04 PM
OK, it says "No such file or directory"
Strange...

Try


sudo service network-manager start

and enter your password at the prompt. Any bad messages? Is the file above created?

ihartmydoghead
August 17th, 2011, 02:39 AM
It says "Job is already running: network-manager"

ihartmydoghead
August 17th, 2011, 03:03 AM
Strange...

Try


sudo service network-manager start

and enter your password at the prompt. Any bad messages? Is the file above created?

It says "Job is already running: network-manager"

dineshs
August 17th, 2011, 06:06 AM
(totally unfamiliar with command line and terminal)
Did you try
Please click on the Network Manager icon on top right of the panel.Ensure that enable networking is ticked.
followed by a
sudo service network-manager restart

ihartmydoghead
August 17th, 2011, 05:08 PM
Did you try followed by a
sudo service network-manager restart
Will try it. Thanks...

ihartmydoghead
August 17th, 2011, 09:02 PM
Nope.

pi.boy.travis
August 17th, 2011, 10:12 PM
Rather than mess with the state files, maybe try rebooting the laptop?

dineshs
August 18th, 2011, 06:06 AM
Nope.You mean when you click NM icon and try to tick 'enable networking' you are not able to?
Is 'enable networking' greyed ?
Did you check BIOS settings? Is it enabled there?

ihartmydoghead
September 1st, 2011, 06:17 AM
I've tried everything that was suggested. Finally, i bypassed wireless router, and it will work with a cable, and after 'learning' the wireless network, will work temporarily uncabled, but always 'forgets' wireless network again, and needs to be cabled again. ??? Another computer on network works perfectly, so WTH ? For now, running cabled.