View Full Version : [ubuntu] 8.04 to 10.04 upgrade problem

August 14th, 2011, 04:13 AM
I recently ran a distribution upgrade to move from 8.04 to 10.04. the upgrade seemed to be running fine. After about 2 hours, it seemed to be just about finished with the installation stage indicating installation would be complete in 1 minute. At that point an error occured indicating the it could not install intramfs-tools. It then terminated the upgrade and indicated that my system may be unstable.

I restarted the computer and it booted and came up. I received a message indicating my boot space only had about 2.5MB left so I think there may be something from the upgrade that did not get cleaned up there. Using aptitude, I checked the package state of initramfs-tools. The package state is C indicating that it was left partially configured.

I've been using Ubuntu for some time now but haven't battled with many upgrade problems. What should my course of action be to determine the state of my upgrade. How do I clean up my boot partition?

August 14th, 2011, 05:46 AM
Hi, have you tried to "Fix broken packages" from synaptic? The option is under edit in synaptic.

And this (http://ubuntuforums.org/showthread.php?t=1713209)

No trees were harmed in creating this message.
However, a large number of electrons were terribly inconvenienced.

August 14th, 2011, 06:00 AM
I've only used aptitude for package management. I did just try to run aptitude and it tried to reinstall initramfs-tools. It appeared to error out because there is not enough space in my boot partition. Maybe I was supposed to clean up that partition some how before doing the upgrade. I'm not sure how to clean up the boot partition. Searching around, it sounds like old kernels (I assume from previous upgrades) need to be deleted. If this is what needs to be done, how does one accomplish such a thing?

August 14th, 2011, 06:17 AM
From memory I do not know, but there sure are a lot of hits when searching for Fix a Failed INITRAMFS Update

I hope this (http://www.google.com/#hl=en&cp=29&gs_id=5&xhr=t&q=Fix+a+Failed+INITRAMFS+Update&pf=p&sclient=psy&site=&source=hp&pbx=1&oq=Fix+a+Failed+INITRAMFS+Update&aq=f&aqi=&aql=&gs_sm=&gs_upl=&bav=on.2,or.r_gc.r_pw.&fp=dea6519f27a77d79&biw=1920&bih=914) link might help you.

And BTW what is a boot partition? Do you in fact have a partition named boot? Or are they referring to / (root) partition? EDIT, they must be talking about the directory /boot

August 14th, 2011, 07:24 AM
I believe boot partition is the correct term and it is located at /boot. The builders of this machine at Dell seem to have created a separate boot partition on the disk.

I used aptitude to delete about 6 older kernels. initramfs seems to have installed correctly as part of the kernel removel process. I wasn't sure if there was something else I should do to clean up after the failed upgrade process so I went back to update manager and it now suggested a partial upgrade and seemed to know that the upgrade process had failed previously. This option did not present itself after the intial initramfs-tools failure so creating more space in /boot must have helped. So I did the partial upgrade and am keeping my fingers crossed that everything is installed correctly now. I guess time will tell.

I read some from the search parameters you suggested. It sounds like I was lucky that my system came up after re-booting. They suggested fixing it all before rebooting. Maybe I'm having a little luck tonight after all.

Thanks for your help and support.

August 14th, 2011, 07:33 AM
You are welcome, glad you got it sorted.
/boot is a directory. Just for giggles post the output of
sudo fdisk -lu if you don't mind.

August 14th, 2011, 08:35 AM
Here it is. I believe the boot partion is the one with an ID of "b". Thanks again.

Disk /dev/sda: 250.0 GB, 250000000000 bytes
255 heads, 63 sectors/track, 30394 cylinders, total 488281250 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Device Boot Start End Blocks Id System
/dev/sda1 63 96389 48163+ de Dell Utility
/dev/sda2 96390 4305419 2104515 b W95 FAT32
/dev/sda3 * 4305420 4707044 200812+ 83 Linux
/dev/sda4 4707045 488279609 241786282+ f W95 Ext'd (LBA)
/dev/sda5 4707108 7309574 1301233+ 82 Linux swap / Solaris
/dev/sda6 7309638 488279609 240484986 83 Linux