PDA

View Full Version : [SOLVED] can't move windows anymore



vanspud
August 10th, 2011, 08:50 PM
Hi,

ubuntu 11.04, sony vaio laptop

I was messing around with trying to install themes and I must have knocked something important in compiz settings as now I am unable to move my windows around on my desktop.

Now whenever I open an application, however it opens I can't move it.

Any idea's how I can enable window movement again?

Many thanks.

HiFlight
August 10th, 2011, 10:11 PM
Hi,

ubuntu 11.04, sony vaio laptop

I was messing around with trying to install themes and I must have knocked something important in compiz settings as now I am unable to move my windows around on my desktop.

Now whenever I open an application, however it opens I can't move it.

Any idea's how I can enable window movement again?

Many thanks.


I think it is inherent in Unity in 11.04 as I have the same problem. I solved it by using Classic desktop.

vanspud
August 13th, 2011, 06:56 PM
I did switch to classic desktop and couldn't move windows. Running "unity" from terminal fixed it and now I can move the windows again.

N1GHTS
August 13th, 2011, 07:07 PM
I had this happen to me like a million times since its very easy to break the Compiz settings so this is how to get it back to normal:

Type "ccsm" in a terminal; Alternatively use System / Preferences / CompizConfig Settings Manager. Then click the Preferences Tab, then click the "Reset to Defaults" button.

Ideally you should Export your Compiz settings when you are happy with your settings so you can Import them in emergencies, but the default is a great fall back plan.

The reason your solution worked was because the Compiz settings were being set to the defaults for Unity and Ubuntu Classic, so it naturally undid your messed up Compiz settings. So it only got fixed by accident.

HiFlight
August 13th, 2011, 08:00 PM
I think it is inherent in Unity in 11.04 as I have the same problem. I solved it by using Classic desktop.


I finally got my issue fixed...I needed to go into the compiz menu and uncheck and recheck "Windows Decoration" and suddenly the title bars reappeared on my open child windows when running unity. Everything was always normal in classic mode.

wascrash
August 28th, 2011, 07:17 PM
I had this happen to me like a million times since its very easy to break the Compiz settings so this is how to get it back to normal:

Type "ccsm" in a terminal; Alternatively use System / Preferences / CompizConfig Settings Manager. Then click the Preferences Tab, then click the "Reset to Defaults" button.

Ideally you should Export your Compiz settings when you are happy with your settings so you can Import them in emergencies, but the default is a great fall back plan.

The reason your solution worked was because the Compiz settings were being set to the defaults for Unity and Ubuntu Classic, so it naturally undid your messed up Compiz settings. So it only got fixed by accident.

Thank you so much for this. I just installed Ubuntu 2 days ago and have not a clue about linux. I did the same thing.Downloaded an app from software center to get that cube desktop lol. well it didn't work and when i tried to go back I could not move my open windows and the top of them were gone. Unity worked fine but I don't like it. I like the classic. I didn't have any compiz on preferences so I tried the terminal like you said and it told me what to type to install compiz config. After that I reset to defaults and rebooted and worked like a charm .....Thank you.

mrincredible
January 4th, 2012, 04:45 PM
I had the same problem in 11.04 after switching to "Classic Desktop". I had to run ccsm and tick the "Move Windows" option.

simptechmike
February 5th, 2012, 08:03 AM
I had the same problem in 11.04 after switching to "Classic Desktop". I had to run ccsm and tick the "Move Windows" option.

This is exactly what fixed this issue for me. Just wanted to add that the "Move Windows" option is under "Windows Management" in CompizConfig Settings Manager (CCSM)