PDA

View Full Version : [SOLVED] acer aspire 48830gt ......no sound



naifnoon
August 7th, 2011, 12:50 PM
good day everyone

i'm new to linux and i installed ubuntu 11.04 to my laptop Acer Aspire 4830TG

it is great except the sound.

i have no sound at all.

any help plz.


thanks

SalHelder
August 7th, 2011, 02:12 PM
Type in the terminal:

gnome-volume-control

On the window that opens tweak options accordingly.

naifnoon
August 7th, 2011, 05:44 PM
i tried it before

nothing

SalHelder
August 7th, 2011, 05:50 PM
That's strange.

Try typing in the terminal:
gstreamer-properties

And change all options to ALSA, reboot and see if it solves it.

fdrake
August 7th, 2011, 05:52 PM
i tried it before nothing
by "nothing" it means that a windows pops up and u can change the volume but it does not work? or it does not show the pop up window, but instead an error msg?

naifnoon
August 7th, 2011, 06:07 PM
That's strange.

Try typing in the terminal:
gstreamer-properties

And change all options to ALSA, reboot and see if it solves it.

i did it

i reboot 2 times no sound

naifnoon
August 7th, 2011, 06:10 PM
by "nothing" it means that a windows pops up and u can change the volume but it does not work? or it does not show the pop up window, but instead an error msg?

the window pop up and i can change

no sound

SalHelder
August 7th, 2011, 06:22 PM
Are you sure you're computer model is Aspire 48830gt? I don't seem to find it anywhere to see the specs of it.

naifnoon
August 7th, 2011, 06:28 PM
Are you sure you're computer model is Aspire 48830gt? I don't seem to find it anywhere to see the specs of it.

sorry it is one 8:

Acer Aspire 4830TG Timelinex

fdrake
August 7th, 2011, 06:42 PM
output of :

lspci -vvv | nl | grep Audio

naifnoon
August 7th, 2011, 07:01 PM
output of :

lspci -vvv | nl | grep Audio

52 00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 04)

fdrake
August 7th, 2011, 07:23 PM
see if this works..



ops!
sorry i just noticed the difference in the model u r using

reboot and test.

source : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/783582

fdrake
August 7th, 2011, 07:56 PM
wget -O run.py http://www.alsa-project.org/hda-analyzer.py
sudo python run.py

select enable EAPD in Node[0x1b]

reboot and test.

source : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/783582

naifnoon
August 7th, 2011, 08:42 PM
wget -O run.py http://www.alsa-project.org/hda-analyzer.py
sudo python run.py
select enable EAPD in Node[0x1b]

reboot and test.

source : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/783582


thank u very very very much man

it works finally

fdrake
August 7th, 2011, 08:47 PM
thank u very very very much man

it works finally
I am happy for you.
make sure to mark this thread as "SOLVED" so someone else with your problem will find it.

ahref
August 7th, 2011, 09:07 PM
Hello,

Been following this thread enabling EAPD on the node solves the problem but only for one boot cylcle, on reboot I need to renable it to get sound back.

Is there a way to enable this on startup some sort of script or something. Perhaps the alsa conf file in modprobe could do it.

Anyone know of a way?

Thanks

fdrake
August 7th, 2011, 09:39 PM
Hello,

Been following this thread enabling EAPD on the node solves the problem but only for one boot cylcle, on reboot I need to renable it to get sound back.

Is there a way to enable this on startup some sort of script or something. Perhaps the alsa conf file in modprobe could do it.

Anyone know of a way?

Thanks

what release?
output

lsb_release -a

by the way I suggest you to open a new thread with your info. it will get you quicker to a solution.

ahref
August 7th, 2011, 09:44 PM
Exactly the same as the guy posting, I didnt think i should make a new thread when this one has a solution and had active posts.

so to reiterate:

Ubuntu Natty, Acer Aspire Timeline X(4830G), Following the steps in this thread enables sound for ONE boot. Is there a more permanent solution :D?

fdrake
August 7th, 2011, 10:01 PM
Exactly the same as the guy posting, I didnt think i should make a new thread when this one has a solution and had active posts.

so to reiterate:

Ubuntu Natty, Acer Aspire Timeline X(4830G), Following the steps in this thread enables sound for ONE boot. Is there a more permanent solution :D?

well the thing is that this may depend on the release you are using, since the links i checked did not describe this problem.
beside if you are looking for help ppl won't search for a thread tagged as "solved" unless the "naifnoon" user changes it.

provide a link to your new thread in here so ppl will know..

lmm5247
June 25th, 2012, 05:21 AM
That's strange.

Try typing in the terminal:
gstreamer-properties

And change all options to ALSA, reboot and see if it solves it.

had the "no sound" problem, running 12.04 64-bit on a 4830t, kernel 3.2.0-23. used the above command, changed plugin to ALSA, rebooted, and it works! :D speakers and headphones work, no mic yet though...