View Full Version : [ubuntu] Cannot connect to xp share

August 3rd, 2011, 12:04 PM
I created a root drive share and set it so only my user can access it (in xp). But ubuntu says "Failed to mount Windows share."

August 3rd, 2011, 12:20 PM
Hi l07,

Would it be possible for you to please provide some more information with regard to the steps you are taking to access your XP share?


August 3rd, 2011, 12:36 PM
I go to network, click workgroup, my pc name, share name.
There aren't particularly any steps to take. I can describe my config: on xp I have comodo firewall, and it's set to enable lan traffic as far as I can tell. I tried sharing ubuntu's folder, installed service as prompted, and windows sees it but says "untupc not accessible. You mightn't have perms to use this net resource. The net path wasn't found." I used network magic before, but it wouldn't let me set access permissions, so I'm trying to do this manually.

After I restarted session as prompted after share service installation, I now get the msg "failed to retrieve share list from server." after clicking on win net.

August 3rd, 2011, 11:43 PM
Still need help.

August 7th, 2011, 10:41 AM
Hi, sorry for the delay. I was just checking how my own Ubuntu / Windows machines were configured.

From your Ubuntu PC have you tried going to Network > Windows Network and selecting the name of the workgroup?

August 7th, 2011, 12:57 PM
Of course. That's how I access it.

August 7th, 2011, 01:22 PM
A lot of what I'm asking for is probably overkill but rather that ask you in steps it's best to ask this all at once. Please post the output of each of the following commands from your Ubuntu machine:

testparm -s
smbtreeIn the meantime instead of browsing to WinXP try accessing it directly by ip address:

nautilus smb:// to the ip address of the WinXP machine.

Try it once as is and then try it after temporarily disabling the firewall on both WinXP and Ubuntu. If you haven't done anything to the Ubuntu firewall you don't have to do anything on Ubuntu but you will on WinXP.

August 7th, 2011, 01:23 PM
Can you ping the Windows PC from the Ubuntu PC and vice versa?

August 7th, 2011, 01:27 PM
Try this:

Open a terminal and enter:


In linux you can do almost everything from the command line.
Most Graphic programs are just front ends to command line programs.
When you run a program from the command line you see error messages that might be surpressed by the graphic user interface.

August 7th, 2011, 01:53 PM
I tried sharing ubuntu's folder, installed service as prompted, and windows sees it but says "untupc not accessible. Missed that from your earlier post. Sorry, but I need the output of this command as well:

net usershare info --long

August 10th, 2011, 08:59 AM
I'm away from my setup, I will reply as soon as I'm back and able to post the output.

August 13th, 2011, 12:10 AM
testparm -s
server string = %h server (Samba, Ubuntu)
map to guest = Bad User
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
dns proxy = No
usershare allow guests = Yes
panic action = /usr/share/samba/panic-action %d

comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
browseable = No

comment = Printer Drivers
path = /var/lib/samba/printers


[no output]

net usershare info --long
guest_ok=nPinging works both ways. Launching nautilus from cmd prompt yields the same result as browsing to the share.

August 13th, 2011, 04:40 PM
And what is the output of this command:

ls -al /media/files

August 16th, 2011, 11:40 PM
I'd rather not post the output because it contains the names of sensitive files. It looks like a regular dir listing. Are there no other suggestions?

August 21st, 2011, 06:20 AM
Still need help.

Enter help out mode.