PDA

View Full Version : [SOLVED] RT2860sta drivers not working



surajrajpurohit
July 31st, 2011, 03:51 PM
hello
I'm using ubuntu with kernel 2.6.38 which is not supporting my RALINK wifi card. i have installed rt2860sta drivers from ralink website and blacklisted all others remaning drivers. but still Wicd is not detecting any wifi drivers and ifconfig and iwconfig are also not showing any wireless extension.

lsmod | grep rt2860sta showing
rt2860sta 816407 o
its showing program using this drivers 0;

i have also tried by loading another kernel 2.6.35 which is having rt2860 drivers inbuilt...but the said part of story is GRUB is not loading new kernel.

im trying to install this drivers from last 2 months...i would b very thankful if anybody here help me...

surajrajpurohit
July 31st, 2011, 03:59 PM
plz........help

chili555
July 31st, 2011, 04:19 PM
Let's see what wireless card you have. Please run and post:
lspci -nn | grep 0280Thanks.

surajrajpurohit
July 31st, 2011, 04:27 PM
Let's see what wireless card you have. Please run and post:
lspci -nn | grep 0280Thanks.
for lspci -nn | grep 0280 i got
01:06.0 Network controller {0280} ralink devic [1814: 3060]

chili555
July 31st, 2011, 04:44 PM
rt2860sta is not correct for your device; you need rt3562sta. Here is a pretty good tutorial: http://ubuntuforums.org/showthread.php?t=1608095&highlight=rt3562sta

Post back if you get stuck or need further assistance.

surajrajpurohit
August 1st, 2011, 07:36 AM
thanks chilli555,
the drivers rt3562sta got loaded n working.
iwlist is showing the network available....
i got new interfrence ra0;
iwconfig is showing
ra0 RAlink STA ESSID: "" nickname; "RT3562sta"
mode:auto
& son on
BUT

My wicd network manager is not, its not showing any APs
i tried connecting using
iwconfig ra0 essid "suraj" key "hs6837"
but the output is Error for wireless request "set Encode" (8B2A)
invalid arument......

chili555
August 1st, 2011, 12:47 PM
iwconfig ra0 essid "suraj" key "hs6837" Is it incorrect because WEP keys can be 5, 10, 13 or 26 characters and yours appears to be 6?

Does it scan?
sudo iwlist ra0 scanDid you make the changes to config.mk to be managed by Network Manager when you are actually using Wicd and not NM?

surajrajpurohit
August 1st, 2011, 01:03 PM
my wireless router has WPA2psk protection.
i have made the changes in config.mk i have change WPA_supplicants=y and nxt line also =y..
dat's it..
and yes iwlist scan is working fine..im getting available networks...
and also i have blacklisted remaining drivers...rt2800pci,rt2899lib etc...

chili555
August 1st, 2011, 01:57 PM
my wireless router has WPA2psk protection.
i have made the changes in config.mk i have change WPA_supplicants=y and nxt line also =y..
dat's it..
and yes iwlist scan is working fine..im getting available networks...
and also i have blacklisted remaining drivers...rt2800pci,rt2899lib etc...It sounds to me like it's working fine! Does Network Manager see those same networks? Can you click the icon and connect?

surajrajpurohit
August 1st, 2011, 02:23 PM
im using KDE so der is no network manager...ii hve wicd manager instwdd of network manager... the problem is my wicd is not showing any networks.....to get connect..?

chili555
August 1st, 2011, 04:16 PM
When you click the Wicd icon, do you see the tab for Preferences? Is it set to use ra0 instead of wlan0?

surajrajpurohit
August 1st, 2011, 05:07 PM
Hurry!!
Its working....thank q very much......i'm very thankful to you for ur cooperation and patience....
i've renamed wlan0 to ra0 in wicd and its working.....
it's like my dream come true........and its dediceted to u...chilli555....thank q once again.....

chili555
August 1st, 2011, 05:18 PM
Great job. You were very patient and understanding, too. Glad it's working. Would you please use thread tools at the top and Mark Solved?

surajrajpurohit
August 1st, 2011, 05:42 PM
thnaks once again 4 advicing.....i hve marked..as solved