View Full Version : [ubuntu] USB key created on MAC OS X won't boot Ubuntu on hp compaq nc6320

July 31st, 2011, 02:01 PM
Hello, I am trying to boot Ubuntu 10.04 from a USB key created on Mac OS X. I know 2 things for facts:
The USB key can be bootable
The laptop can boot from the USB

I recently did the same process with Fedora 15 and booted successfully on this same laptop.

I've followed the exact instructions on the Ubuntu website for creating a USB key on Mac OS X and the error I receive when I try to boot the USB is:

Non-System disk or disk error
replace and strike any key when ready

Any help would be greatly appreciated.

Also, I've tried to boot this USB stick on the Mac that created it and during the boot screen it doesn't even show up.

July 31st, 2011, 02:43 PM
Though I am curious why this happened I've found a solution enough for me. Used unetbootin. I'm not going to mark this solved because I don't know that I've gotten to the root of the problem...but this seems to have worked for now. Might be worthwhile for someone with more experience than me to look into this.