View Full Version : [SOLVED] Natty, Compiz Workspace switcher can't switch down from w/space #1

Pablo Pablovski
July 16th, 2011, 09:27 AM
Hi all.
I've just (finally) upgraded to Natty from Maverick. After the faffing around to restore my favoured AWN and Compiz combo, all's now ok, except for one annoyance to do with Compiz (0.9.4) and the workspace switcher.

I can use the mousewheel to rotate workspaces up/down (actually, left/right) to go from 1->2->3->4->5->6->1.. and 6->5->4->3->2->1, but it won't rotate down / left from 1->6. It works ok if I use <Ctrl>left arrow from w/space #1.

I've checked the mappings for Button4 and Button5 in CCSM, and there's no clash. So, am I right in thinking this is probably a bug? Has anyone else had this problem and is there a fix? Is downgrading to Compiz 0.8 likely to fix it?

Thanks all..


Pablo Pablovski
July 16th, 2011, 09:40 AM
Solved! Instead of mapping Button4 and Button5 to Move W/space Left and Move W/space Right in CCSM, I mapped them to Next / Previous w/space and it works as required.

S'easy this Linux lark...