View Full Version : [SOLVED] GNOME panel appears in KDE

July 14th, 2011, 11:11 AM
Hello to everyone!
I am using Ubuntu 11.04 with both GNOME and KDE environments and I like and use both.
I had a problem in GNOME with the skype system tray icon which didn't appear when skype was starting. After reading this article (http://forum.skype.com/index.php?showtopic=818699) I added the "gnome-panel --replace" command to the start up applications. Then everything was working fine.
But when I logged in to KDE I had GNOME panel as well! Which is normal since I the command myself.
I tried to remove the "gnome-panel --replace" command but then I didn't have the panel when logging in to GNOME!
Do you have any ideas how to solve this???

July 14th, 2011, 11:14 AM
Try this script, it should restore the default panel settings

July 14th, 2011, 12:56 PM
I just tried it! and it didn't work...
It messed up my panel actually and I still have GNOME panel in KDE. If I remove the "gnome-panel --replace" command from the start up then I get no GNOME panel when I log in to GNOME and of course Skype icon does not appear! Now, I have to make GNOME panel as it looked before as well!! I forgot to save...
I was trying to find a file where GNOME or KDE stores start up commands for every desktop environment... Do you think this might work?

July 14th, 2011, 11:32 PM
How about adding this line to the concerning .desktop file in "~/.config/autostart"?: