View Full Version : [SOLVED] Intel DQ67SW board

July 13th, 2011, 02:56 PM
I've been searching the usual places (here, linuxHCL) and haven't been able to find any reviews on a specific board.

Has anyone here run ubuntu on a computer based on intels dq67sw desktop board? In particular, I was wondering if the built-in video card handled dual-monitors in ubuntu without significant headaches?

In case it matters, the board is based on intels Q67 express chipset with 2nd generation VPro processor.



July 19th, 2011, 06:13 PM
No replies, but I chose to take the plunge anyways. Its two days in, and so far things are working flawlessly. Even virtualbox is running win7 without the headaches some cards have!


July 20th, 2011, 05:27 PM
I'm also about to purchase this board, so I'm interested in your experience of it running linux.

Did you get dual monitors to work with the integrated graphics?

And how is the overall compatibility, sound, integrated NIC etc?

Also, I've been reading about this weird stability issue (http://communities.intel.com/message/131722) when having only SSD:s connected to this board (i.e no HDD:s), which is my planned setup. Have you experienced any stability issues?

Thanks in advance :)

July 21st, 2011, 08:18 PM
The dual monitors worked perfectly using the intigrated graphics. Hooked up 2 monitors with DVI cables (the czard has 2 DVI outputs). After installing ubuntu the monitors were mirrored, but I simply opened the monitors dialogue box and reconfigured as an extended desktop. Has worked without flaw for a week now. I can even get virtualbox to run win7 in one monitor without hiccups.

Sound and network also work flawlessly. The T1000 runs as fast as it should, unlike the last T1000 ethernet card I had. I've had no stability issues, but I'm also using a HDD instead of a SSD.

Attachment shows my desktop, with virtualbox running win7 on the right monitor.


July 12th, 2012, 03:15 PM
Hey guys,

I also own a DQ67SW but have problems with crackling sound on my right audio channel. So I am stuck with mono sound at the moment.

I am running 12.04 AMD64. Problem started with 11.10. 11.04. worked.

Can you confirm this problem?