PDA

View Full Version : [SOLVED] Foreign keyboard with accents (dead keys?)



dargaud
July 11th, 2011, 02:24 PM
Hello all,
I just configured a PC in french and when the installer asked me if my keyboard had dead keys, I changed to one without dead keys.
So instead of pressing the [^] next to [p] and then [o] to obtain a , I get ^o.

So now it doesn't work properly and it's my fault, but I cannot find where to change that option. I went to [System settings][Input devices][Keyboard] and tries some of the obvious choices: Generic, Generic Intl, Logitech Internet... The keyboard is a Logitech Y-ST39.

I also looked in[System Settings][Locale].

Where is that dead key option ?
Thanks

enimeizoo
July 14th, 2011, 06:11 PM
Hello,
Did you check systemsettings > input devices > keyboard. In the layout tab, you can configure layouts.
You can add a layout, you choose the language, the actual layout, and you have a variant option. Here you can choose if you want dead keys or not. It is actually pretty well hidden :P
I actually still prefer xmodmap rather than layouts features since I need a very versatile keyboard.

dargaud
August 25th, 2011, 02:37 PM
Thanks a lot, that solved it. I just set it back to 'default'.