View Full Version : [ubuntu] 11.04 "Device not ready"

July 11th, 2011, 10:22 AM
Hey guys,

I have a Lenovo ThinkPad Edge E520 (1143CTO) and I'm having problems getting my wireless NIC to work, as far as I can tell the drivers and firmware are all installed and the device is working.

I have searched around and have done all the fixes I can find online, this is my first 'real' experience with Linux, so patience is appreciated, as is any help I can get. I also had this problem with Linux Mint 11.

It appears that the model of my card is BCM43224, but it doesn't show up anywhere in the with any commands?

sudo lshw

*-network DISABLED
description: Wireless interface
product: Broadcom Corporation
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:09:00.0
logical name: eth2
version: 01
serial: ac:81:12:3e:1d:ca
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=wl0 driverversion= latency=0 multicast=yes wireless=IEEE 802.11abgn
resources: irq:19 memory:e1d00000-e1d03fff sudo lspci

09:00.0 Network controller: Broadcom Corporation Device 0576 (rev 01) I have tried the Broadcom STA drivers and have also tried the command:

sudo apt-get install b43-fwcutter firmware-b43-installer sudo rfkill list

0: brcmwl-0: Wireless LAN
Soft blocked: no
Hard blocked: no Yet, sudo lshw still shows it as disabled!

Nothing I can find just seems to work. Any help at all is appreciated and I will try any suggestions as-long as you can provide me with the command http://forums.steampowered.com/forums/v4_images/smilies/smile.gif

I have tried EVERY fix I can find!

P.S. This is the fourth forum I am posting it on as I am in desperate need of help.


July 11th, 2011, 03:27 PM
Please post:
lspci -nn | grep 0280
sudo rfkill list all
dmesg | grep -e b43 -e wl
lsmod | grep -e b43 -e wlThe pipe symbol | is on the right side of my US keyboard on the same key with \. Thanks.

July 12th, 2011, 12:44 AM
I see you are helping alot of people with this problem, sadly their solutions don't work for me. I appreciate your help!

> lspci -nn | grep 0280

09:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:0576] (rev 01)

> sudo rfkill list all

0: brcmwl-0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no
2: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: yes
Hard blocked: no

> dmesg | grep -e b43 -e wl

[ 11.211707] wl 0000:09:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 11.211720] wl 0000:09:00.0: setting latency timer to 64

> lsmod | grep -e b43 -e wl

wl 2568244 0
lib80211 14991 2 lib80211_crypt_tkip,wl

Thanks again!

July 12th, 2011, 01:00 AM
acer-wireless: Wireless LAN
Soft blocked: yesThat means, roughly, that software is blocking the wireless. In this case, I suspect the module acer-wmi is not telling the kernel that the wireless switch is on or off.

Hey! Wait a minute! An Acer module on a Lenovo?? Well, it's a known bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/668234

Let's check:
lsmod | grep acerIf acer-wmi is loaded, let's unload it:
sudo rmmod -f acer-wmiDid your wireless spring to life? If so, let's blacklist it:
sudo su
echo "blacklist acer-wmi" >> /etc/modprobe.d/blacklist.conf
exitIf that doesn't fix it, post back and we'll dig deeper.

July 12th, 2011, 03:48 AM
I... Love... You!

I did see that acer wireless somewhere else on a forum but they seemed to ignore that and it worked?

July 12th, 2011, 05:10 PM
Thank you.
I had the same problem on a Lenovo B560

August 9th, 2011, 11:03 PM
My god, your a genius! worked on my e520 as well! You must be RMS. Please accept 12 Internets.