View Full Version : [ubuntu] Cannot Connect to Internet with HP Touchsmart

July 11th, 2011, 03:32 AM
Nevermind. I found the solution.

I just installed Ubuntu on a HP Touchsmart TX2 today. I've never used or installed Ubuntu before, but I did try the demo before hand and loved it. Within the demo, the internet worked fine. I could connect to my router just fine. Connecting also worked flawlessly during the installation of Ubuntu.

Only after my computer restarted (to finish the installation) did I notice that I couldn't connect to the internet. I was also greeted by the Additional Drivers window telling me I need to activate my Broadcom STA Wireless and my Software Modem. But every time I tried to activate them, I received an error.

For the Broadcom:

"Sorry, installation of this driver failed.

Please have a look at the log file for details: /var/log/jockey.log" (The log file was many word pages long, so I won't post it. If you need it, I'd be happy to provide it for you)

for the Software Modem:

If this driver is not enabled, you will not be able to use your modem.

SystemError: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/restricted/s/sl-modem/sl-modem-daemon_2.9.11~20100718-4_i386.deb Could not resolve 'us.archive.ubuntu.com'

I'm guessing I need to be connected to the internet to activate the drivers...but from what it seems, I cannot access the internet without installing these drivers. This is such a paradox. xD Although, I don't know if this is for certain yet. I'm still quite a newbie at Ubuntu. If you can offer any help as to how I can connect to the internet (preferably through wireless), it would be much appreciated! :D:D

I'm sorry if you've answered this question hundreds, or even thousands of times. I did a quick search, and could not find anything helpful. (Although, I probably could've searched longer...I'm so impatient...that's quite a fault of mine). And if you need more information [that retains to my problem], all you have to do is ask. Oh, and if this is in the wrong forum, I'm very sorry about that.

Thank you for your time and answers.