View Full Version : [SOLVED] network printer not recognized

July 8th, 2011, 12:09 AM

I have a desktop and a laptop connected by ssh (Places>Connect to Server). This works OK for file sharing but the laptop does not recognize the 2 printers attached to the desktop machine. As I understand (??) it, if the 2 printers are set up as 'shared' in CUPS (as they are on the desktop) then they should be recognized by the other machine on the network. But this is not happening. Is this the right way to network printers?

Any help much appreciated.

July 8th, 2011, 02:13 AM
I think the desktop with the printer attached also has to publish the printer. Open Printing > Server > Settings and check off Publish. See attached.

July 8th, 2011, 03:45 AM

Printing > Settings > Publish is checked already

July 8th, 2011, 04:38 AM
Solved, yah yah yah!!

On the laptop, Printing > Settings > Show printers shared by other systems checked

Printing > Settings > Connect > CUPS server set to (desktop address)

Chili555, you pointed the way. Thanks :D