View Full Version : [SOLVED] OS X 10.6.7, Mac Pro Bootcamp problem

Chris Richard
June 30th, 2011, 03:51 PM
Before I get into describing the problem here, I'd like to clarify a couple of things.

A) I have done many hours of research on this problem.

B) I have extensive experience formatting drives, and only a little knowledge about boot systems.

C) Most of the forum posts regarding similar problems have received replies like "Huh! I run [fill in the blank} and I don't have that problem." (NOT helpful at all, and wasted a lot of my time.)

D) Do me and every other user out there that might find this with a Google search a huge favor, please? If you have a clue or an idea about how to solve this, please do reply. If you don't, please don't waste everybody's time by telling us all, "It works fine for me."

I've DONE the research. I've READ the documentation. Not one single solution I've found so far works on my system. Telling me it works on yours not only doesn't help me, but implies that I haven't "RTFM," (which after a solid week of researching this, is frankly insulting.)

The system:

Model Name: Mac Pro
Model Identifier: MacPro1,1
Processor Name: Dual-Core Intel Xeon
Processor Speed: 2.66 GHz
Number Of Processors: 2
Total Number Of Cores: 4
L2 Cache (per processor): 4 MB
Memory: 2 GB
Bus Speed: 1.33 GHz
Boot ROM Version: MP11.005D.B00

History before the problem:

Running Bootcamp XP dual boot (upgraded to SP 3 after installation ~ problem free) for about two years.

One year ago, ran out of room on the HD. Uninstalled Windows, and reinstalled on a secondary drive. Upgraded to SP 3. No problems.

One week ago decided to try installing Ubuntu using only the distribution burned to CD (no refit ~ and remember, Windows is on a secondary HD, with its own partition. I used the Ubuntu simple partitioning option (to install next to Windows), and it fails right at the end because Grub can't install. Try installing to every other available disk. All fail.

One odd thing: When option key is held during reboot Ubuntu CD shows up as "Windows." Also, I've attempted various installation methods, during which (I forget the configuration) one actually did show up in the option key menu, and it said "Windows" right next to the actual Windows boot disk. I don't know if that indicates some kind of conflict in Bootcamp or not. Maybe it does? Because after another reboot, they both (the real Windows and the Ubuntu disk ~ which was showing up also as Windows) disappeared from both the Bootcamp preferences menu, and the option key menu, and the box would no longer boot in anything but OS X no matter what I did, plus Boot champ, though it showed the Windows disk, would fail on reboot as well.

I could though, still see the files for Windows in OS X, so I saved all my files to another drive, wiped the entire drive containing the partition (remember, this is a secondary drive now), and started over.

This time, I used Bootcamp to install Windows again, to the secondary drive (there is NO room left on the OS X drive for this), and that went fine. Then, I ran the Unbuntu installation from the CD again, using the "Next to" option, again, and am now getting the Grub installation error toward the very end of the process. None of the disk choices work. I've tried them all.

I have also tried refit, which on this machine, does not work at all. I've not seen the refit startup screen at all no matter how many times I reboot, shut down etc. A tiny bit of research reveals others who were previously running refit began having problems with upgrading to Snow Leopard. Clearly there are problems running it on Snow Leopard.

I've also seen quite a lot of responses to similar problems indicating people running systems other than Mac Pros have not seen these problems, which leads me to suspect that (as with many other softwares), there are many problems (this one included) unique to Mac Pro systems. Especially Mac Pros running Windows Bootcamp installs.

Sorry for the length. I just want to be sure I've included enough information.

I have tried several times to install Ubuntu with a couple of different methods:

1) Installing "beside" existing OS's (OS X on main drive, Windows and Ubuntu on the same secondary drive) results in inability to install Grub, so Unbuntu cannot boot.

2) Installing Windows, using Bootcamp, onto a secondary drive, THEN installing Ubuntu onto a SECOND secondary drive (with three partitions ~ one primary for EFI boot, one primary for the OS, and one swap ~ all on the same drive), and still Grub refuses to install, regardless of which drive is selected.

As for the second method, I realized as I was writing this that the problem COULD be related to the fact that the Linux partitions are all at the end of the drive. But as I said, I honestly don't have that much understanding of boot principles. This thought never occurred to me until just now, because Windows installs on the last portion of its disk without trouble, but I think that may be because that isn't where the actual boot files are anyway?

The bottom line is this. I've tried every suggestion and every method I could think of on my own, and though I have managed to solve quite a few problems to the point that I can at least the Ubuntu OS installed without a problem, I have NOT yet solved the problem of how to get Grub installed properly.

Grub will NOT install using the Ubuntu installer so the only option I seem to have now is to install it manually, but no clue how exactly to do this, or where.


In the meantime, I'm going to try one last time to install Ubuntu to it's own secondary drive, into partitions at the beginning of the drive and see if that makes any difference. I suspect it won't, but I guess it's worth a try.

Chris Richard
June 30th, 2011, 04:37 PM
A bit of an update that may shed some light:

Okay, now I've got OS X, Windows, and Ubuntu (which shows up as "Windows"), all showing up in the option key menu. Now, I've been had it at this point before, a couple of times over the last week, but of course Ubuntu can't load since there is no Grub, so I end up with a black screen with nothing but a flashing cursor, which by this point is exactly what I expect. Windows boots fine, for now, but as I said, I have gotten to this point twice before, and both times, after attempting to boot into Ubuntu (I didn't understand at the time what the problem was ~ missing Grub), a few times, both times I eventually lost the ability to boot into anything BUT OS X.

This time I know what's going on, so I'm not about to attempt booting Ubuntu again just yet, until I can figure out how to manually install Grub and where. I know now if I do, I'll lose Windows again.

I think, and you can correct me if I'm wrong (if you really know), that somehow with Grub missing, Bootcamp, or more likely the OS X boot order is getting messed up by screwing with this too much.

I don't know if this has anything to do with it, but it seems to me that Ubuntu showing up as "Windows" in the option key screen, along with the fact that the ubuntu CD shows up in Bootcamp as "Windows on Ubuntu" (by the way, neither Windows NOR the Unbuntu installation show up in the Preferences > Startup Disk screen, only OS X and the CD show up).

The above seems to indicate that the Mac OS is extremely confused as to what is or isn't available for bootable OS's.

Don't know if any of this helps reveal anything useful, but I'm hopeful.

Chris Richard
June 30th, 2011, 09:51 PM

Notice I said in the OP that I have only a little knowledge about boot files. Yeah, well, I do have a LITTLE knowledge, and that little bit, so obvious I forgot all about it, solved this stupid problem once I did remember it.

What is odd though, is that I did try this one time, but it didn't work. When you get the message toward the very end of installing that the Grub could not install, you also get options to change the location. I actually did, in that screen, yesterday, attempt to change it to the correct location (top of the disk), but it didn't work.

Which is strange, because THIS time I simply made the choice to put it there in the first screen, before the actual installation process begins. Low and behold, and no surprise now, really, Everything works well now.

The only question I really have at all now, not that it's a big deal but I am curious, is why neither Windows nor Ubuntu show up in the Mac preferences as startup disks.

Also why both systems show up in the option key screen as "Windows." I mean, I know which one is which by the order I installed them, but I would still like to know why it appears that way, and whether there is any way to fix it.