View Full Version : keyboard and wine

March 3rd, 2005, 05:44 PM
Hi there!

I'm new in Ubuntu and I'm triying to play starcraft trough wine.
I run winesetup and I choose "Managed" under "window mode".that lets my X window system control wine.Everything works fine, only I still see the desktop panels, and since they get bigger due to the resolution change, it's quite annoying.

If I choose "Unmanaged" the panels disapear, but the keyboard won't work (and this is unacceptable in Starcraft).When I quit Starcraft I see in an open terminal the keys I've been tipyng while trying to play Starcraft, so it looks like wine can't "get the focus" to get the keyboard signal.

Is there a way to solve this problem and use the keyboard in the Unmanaged mode??
Thank you for your help.

March 11th, 2005, 02:43 AM
I'm having a similar problem with Counter-strike. If anyone has any advice, please share it.

May 24th, 2005, 09:44 PM
I've tried installing previous versions of wine on my hoary final config and there doesn't appear to be any sort of solution.

Oddly, before I had to reformat I had begun with Warty and upgraded to Hoary in the developmental stage. It worked fine, even after upgrading some apps to Breezy.

Now, after reformat with Hoary final, Wine is useless (without keyboard).


May 31st, 2005, 04:50 AM
Found a fix for this. See this post (http://ubuntuforums.org/showpost.php?p=193419&postcount=5).

I believe the settings created automatically by winesetuptk contain the source of the problem. Best to let wine and wineutils create the proper default directories and settings for you. You can always manually tweak the settings later if you wish.

September 21st, 2007, 12:48 AM
how do you uninstall only "winesetuptk" ?

I'm running Ubuntu Feisty Fawn and my KB doesn't work in XCOM Ufo Defense. I've tried everything and can't figure it out.

September 21st, 2007, 12:54 AM
Dude, this thread is over two years old. None of it actually applies to the current version of Wine anymore.

You can sometimes get the keyboard to work by selecting the "Allow window manager to control the windows" option on the Graphics tab in winecfg. Alternatively, running a game in its own X session will usually correct any keyboard input errors. Click on the "Stuff I've learned about Wine" link in my sig and go to the "Advanced Stuff" section, it explains how to do that.

September 21st, 2007, 01:37 AM
Thread closed. Make a new thread if you have an issue that isn't already covered in a RECENT thread.