PDA

View Full Version : [ubuntu] 10.10 Won't open CD.



Mr_VeRiTy
June 20th, 2011, 02:31 PM
Hey, my sister can't open CDs on her laptop, I made sure to install ubuntu-restricted-extras on her computer and she can open DVDs and data disks. The files burnt to the disk are .wav, and we've tried using vlc, rhythmbox, and tried to open the disk in nautilus, but no success. Does anybody know what's wrong?

Mr_VeRiTy
June 22nd, 2011, 11:48 AM
*Bump*

varunendra
June 22nd, 2011, 01:50 PM
Hey, my sister can't open CDs on her laptop, I made sure to install ubuntu-restricted-extras on her computer and she can open DVDs and data disks. The files burnt to the disk are .wav, and we've tried using vlc, rhythmbox, and tried to open the disk in nautilus, but no success. Does anybody know what's wrong?

Please mention the version of ubuntu you are using.
Can you see the mounted cd or does it seem undetected at all?

Sometimes CDs containing music are mounted to a different directory, I don't remember which one. Maybe output of this command could help (after inserting the disk) if the disk seems undetected:

mount

Mr_VeRiTy
June 22nd, 2011, 01:56 PM
Please mention the version of ubuntu you are using.
Can you see the mounted cd or does it seem undetected at all?

Sometimes CDs containing music are mounted to a different directory, I don't remember which one. Maybe output of this command could help (after inserting the disk) if the disk seems undetected:

mount
It doesn't seem to detect it at all. The output was:
/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/sof/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=sof)

Edit: And the version of Ubuntu is 10.10, Maverick.

varunendra
June 23rd, 2011, 05:45 AM
Hmm.. there happened to be a bug in ubuntu in past that caused audio CDs undetected. Didn't think it could persist in maverick too..

So I tried it myself - burning two wav files on two cd images - one as a data disc and the other as an audio cd, mounted them on a maverick virtual machine, and both are detected fine here.

I guess it's gonna take some research and accordingly maybe some more details about your situation. For now:


can you confirm that your cd is working fine on the same machine using any other OS? (someone tried live puppy linux successfully in another forum).
Is it just one particular disc you tried or many of such kind
Is it a data disc (containing .wav files as data) or an audio cd (.wav burnt as audio tracks)?

Due to shortage of time, I may be late in response, please bear with it!
If you've searched yourself for similar problems, please update the thread with all you've tried so far (providing links to whatever you've tried).

Mr_VeRiTy
June 23rd, 2011, 12:01 PM
Hmm.. there happened to be a bug in ubuntu in past that caused audio CDs undetected. Didn't think it could persist in maverick too..

So I tried it myself - burning two wav files on two cd images - one as a data disc and the other as an audio cd, mounted them on a maverick virtual machine, and both are detected fine here.

I guess it's gonna take some research and accordingly maybe some more details about your situation. For now:


can you confirm that your cd is working fine on the same machine using any other OS? (someone tried live puppy linux successfully in another forum).
Is it just one particular disc you tried or many of such kind
Is it a data disc (containing .wav files as data) or an audio cd (.wav burnt as audio tracks)?

Due to shortage of time, I may be late in response, please bear with it!
If you've searched yourself for similar problems, please update the thread with all you've tried so far (providing links to whatever you've tried).

It's an audio cd (I think it is anyways, I used k3b's default settings whilst burning it.) I've tried a couple of other cds as well, and they didn't work either.. It works fine on another pc running linux mint 11, but I can't try it on the same machine with another OS right now as my sister lives across town and doesn't have any live CD's.

When she tries to open the disk in vlc she gets "Your input can't be opened:
VLC is unable to open the MRL 'cdda:///dev/cdrom'. Check the log for details." I tried to check the log but I couldn't find it in vlc.

varunendra
June 25th, 2011, 07:36 AM
It's an audio cd (I think it is anyways, I used k3b's default settings whilst burning it.)
....
When she tries to open the disk in vlc she gets "Your input can't be opened:
VLC is unable to open the MRL 'cdda:///dev/cdrom'....
How do you try to open it in VLC? The error message suggests that it is indeed trying to detect it as an audio cd (cdda).
I read somewhere (and it makes sense to me) that an audio CD can't be mounted since there is no file system on it (it contains 'tracks' in 'analog' mode). However, actually I've found those files (tracks) to be browsable in /home/<your username>/.gvfs/cdda mount on sr0. Try this location to see if you can find the tracks there.

In your case it certainly seems to me a bug since the same CD opens correctly in Mint 11. Have you tried updating the system?

As for VLC player try Media > Open disc > choose Audio CD > in Disc device field - type /dev/sr0 (originally it should be /dev/cdrom) > click 'Play' button.

If you still have the installation CD, try creating a live USB so that you can boot in live mode while letting the cd drive vacant, then try the same cd to see if it works there. If it does, then it may be some misconfiguration or settings issue.