PDA

View Full Version : [ubuntu] syncing iphone 3G in ubuntu 11



zakiyaa
June 19th, 2011, 08:21 PM
i just got an iphone 3GS and i have been trying everything i can think of to get it to connect to ubuntu 11. i just want to be able to upload mp3s.

- ubuntu recognizes the iphone, two folders pop up when i connect it, one for "iphone documents" and another just for the iphon. i can browse the iphone files.
- rhythmbox doesn't even see the iphone
- itunes 7 in WINE doesn't see the iphone
- banshee 2.0 sees the iphone but when i try to upload files it tells me that the device does not support the mp3 format???
- in virtual box, running windows 7, itunes does not see the iphone.
- virutal box does recognize the iphone, i have tried updating and reinstalling the apple iphone driver but there is always the "!" icon showing that there is something wrong with the driver.

i am at my wits end and ready to return this phone... can anyone give me just one method that works??

zakiyaa
June 21st, 2011, 01:01 AM
bump?

if this is a lost cause, please someone tell me. i feel like there should be an easy fix to this that i am completely missing somehow??

yuanfangcan
June 26th, 2011, 02:11 PM
This is just my experience, which may not help you.
I have a Iphone 3GS.
When I had ubuntu10.4, after I plug in my iphone, both rhythmbox and banshee shows nothing.
When I updated to Ubuntu 10.10, after I plug in my iphone, a error message pop up, said "can not mount" something.
Then I updated to Ubuntu 11.4, iphone is mounted immediately. I can sync using both rhythmbox and banshee. But I can not see the song in my phone sync-ed by banshee. Fortunately Rhythmbox works perfectly for me.

So Ubuntu 11.04 + Rhythmbox worked for my Iphone 3GS

CVGH
June 26th, 2011, 03:33 PM
Have you used ppa's?

https://launchpad.net/~pmcenery/+archive/ppa (https://launchpad.net/%7Epmcenery/+archive/ppa)

Works here on 10.10