View Full Version : [SOLVED] How to set compiz as default in Xubuntu 11.04???

June 16th, 2011, 12:22 AM

I have a laptop on which I just installed Xubuntu 11.04. I know this topic is talked about a lot, but I can't quite seem to find the answer I'm looking for....

How do I set Compiz as the default window manager in Xfce/Xubuntu? I know that my one option is running fusion-icon at startup, however it's a bit clunky to do it that way and I'd rather have it be a little more integrated.

I've read some old threads about changing xfce4-session.rc, however I don't have such a file and I'm guessing it's because Xfce has gone through MANY changes since those threads from 2007.

The other way I've read to do it is here: https://wiki.archlinux.org/index.php/Compiz (http://www.google.com/url?sa=t&source=web&cd=2&ved=0CCMQFjAB&url=http%3A%2F%2Fwiki.archlinux.org%2Findex.php%2F Compiz&rct=j&q=compiz%20default%20xfce%204&ei=-D35TbiFOITs0gHs14iHAw&usg=AFQjCNGlgMoIbojjb1nsAA66mPWYfFY5Tg&cad=rja)

The way I was doing it was in the section on how to make it default for Xfce without fusion icon. However, that didn't work for me either.

I've also looked in the settings manager and settings editor, and I'm not having much luck.

Any help would be much appreciated!

EDIT: Ok, well...apparently it IS working. Another reboot seems to have fixed it I guess. And for any On-lookers, the method in the above link is what worked. While it's from the Arch Linux wiki page, it seems to be a rather generic Xfce configuration, not specific to Arch Linux.