View Full Version : [ubuntu] error, you have held broken packages

June 15th, 2011, 01:22 PM
I am using ubuntu 8.04LTS Hardy Heron.
I sometimes play runescape, but havn't played it for a while; though I recently started trying to play again. I found that I needed to install the new icedtea plugin in order to play, but when I try I get an error message saying something along the lines of:
E: error, you have held broken packages. And I cannot therefore install it and play runescape. I have also checked, and cannot find any broken packages, so I am confused.
Any help would be much appreciated, thank-you.

June 15th, 2011, 04:04 PM
sudo apt-get install -f or in Synaptic, Edit, Fix broken packages.

June 15th, 2011, 04:44 PM
Thank-you so much for replying.

I have tried both of your suggestions, and have now tried to install java runtime environment 1.6, but it says not available?

any help would be appreciated. Thank-you

June 15th, 2011, 05:55 PM
Have you enabled the partner repository? That's where sun-java6-jre is, along with the other sun-java6-* packages. openjdk-6-jre is in main, so if that's the version you want, run
sudo apt-get update && sudo apt-get install openjdk-6-jre

June 15th, 2011, 11:06 PM
Thank-you for replying, I tried this and it partly worked but partly didn't, as some of the files didn't install, and so old files were used it said.

June 16th, 2011, 01:36 AM
Can you post the output from the command?