PDA

View Full Version : [ubuntu] trick- rotate effect in ubuntu



shibu_sawyer
June 15th, 2011, 08:50 AM
NOTE: compizconfig manager is not suitable for ubuntu 11.04 with unity,works fine with 9.10 and 10.10.

Ubuntu enables "Desktop Wall" by default. By holding Ctrl-Alt keys and pressing the left-arrow or right-arrow key each time, it slides through desktop workspaces horizontally for you to choose one to work on. Alternatively, you can change this to a "rotate cube" effect.


http://www.techsupportalert.com/files/images/Rotate-Cube-200-125.png (http://www.techsupportalert.com/files/images/Rotate-Cube.png)Go To System > Preferences > CompizConfig Settings Manager.
(http://www.techsupportalert.com/content/ubuntu-tips-and-tricks.htm#ccsm)
Select "Desktop" from the left panel.
Tick "Rotate Cube".
Select "Enable Desktop Cube" as this plugin is required by "Rotate Cube".
Select "Disable Desktop Wall".

Immediately you can rotate your desktop workspaces in this wayŚ holding down Ctrl-Alt keys, EITHER press the left-arrow or right-arrow key OR left-click the mouse and drag it to left or right.


if there is no compiz manager in your system,download it.. type :sudo apt-get install compizconfig-settings-manager ..:popcorn:

3rdalbum
June 15th, 2011, 09:36 AM
Warning: Do NOT do this on Ubuntu 11.04!

shibu_sawyer
June 15th, 2011, 09:39 AM
why why not,it works fine in 9.10 and 10.10.. i myself checked.. any problem..?

satyanash
June 15th, 2011, 09:45 AM
AFAIK, Ubuntu 11.04 Natty with Unity doesnt use Compiz as it's default compositing manager, so new users may be confused when they try to do this while using Unity which may screw up the screen, and cause some other undesirable effects.
Satyajeet

shibu_sawyer
June 15th, 2011, 09:48 AM
oh thats a big problem..

satyanash
June 15th, 2011, 09:52 AM
oh thats a big problem..

You might want to edit your earlier post, and make people aware that this will not work in Unity.

apollothethird
June 15th, 2011, 09:52 AM
AFAIK, Ubuntu 11.04 Natty with Unity doesnt use Compiz as it's default compositing manager, so new users may be confused when they try to do this while using Unity which may screw up the screen, and cause some other undesirable effects.
Satyajeet

I never saw this warning and have been using CCSM and the effect described by the OP for weeks. I notice many changes does appear to break some other functionality, namely the Top and Side menus. Through trial and error I found that logging out and logging in restores what was broken and the new effect is added in tact.

To logout I either move the mouse around where the Power button is located (but can't be seen) or run gnome-panel in a terminal window.

Other than that, I don't see a problem with CCSM. I'm happy with the visual enhancements I have configured.

-- L. James

--
L. D. James
ljames@apollo3.com
www.apollo3.com/~ljames (http://www.apollo3.com/%7Eljames)

shibu_sawyer
June 15th, 2011, 09:57 AM
@sattu; okay.thanks, i will re-edit now

3rdalbum
June 15th, 2011, 10:46 AM
To clarify: CCSM works on 11.04 because Unity uses Compiz, but the Desktop Cube plugin disables stuff that Unity needs to work. I've also heard people saying that Gnome Classic stops working with Desktop Cube in 11.04 too, but I can't confirm that.

overdrank
June 15th, 2011, 11:37 AM
Moved to Desktop Environments

cpmman
June 15th, 2011, 11:52 AM
Natty with Cube (haven't managed Atlantis with motion yet but it will come)
Unity works perfectly.
Haven't sorted how to resize windows for e.g. Skype yet.

195169

stinkeye
June 15th, 2011, 03:53 PM
You can enable the cube on natty but you need to enable the plugins in a
certain order because of the way the plugin dependencies work.
See this guide. Good idea to make a backup of your current settimgs in
ccsm > preferences

Enable Desktop Cube in Unity, Ubuntu Natty (http://ubuntu4beginners.blogspot.com/2011/05/enable-desktop-cube-in-unity-ubuntu.html)