PDA

View Full Version : [SOLVED] Have to re-login to see Unity.



DinoT1985
June 10th, 2011, 10:58 AM
Ok, this problem came up after the last GDM update.

Upon boot, my resolution is smaller and running Classic. After I log out and login again, Unity is fixed, as is my resolution.

Unity is already set up as the default session in dnmr and is being forced too.

However the resolution change is making me think the proprietary NVIDIA driver isn't activated upon boot.

Any other tricks I can try? GDM has given me many troubles in the past too.

DinoT1985
June 10th, 2011, 11:10 AM
/etc/X11/xorg.conf is the same both upon boot and relogin.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 270.41.19 (buildmeister@swio-display-x86-rhel47-07.nvidia.com) Mon May 16 23:52:12 PDT 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Set GDM To show users and there's only my account.

But if I try to run nvdia-settings upon boot I get the "Device section "Default Device" must have a Driver line." error.

DinoT1985
June 10th, 2011, 02:48 PM
Fixed my problem using these steps.


Install / Re-install proprietary drivers and remove old xorg.conf

At the messed-up desktop, right-click > Create Launcher..., set Name to 'GDM' > and Command to 'gdmsetup'.

Double-click the newly created launcher and select 'Ubuntu Classic' as the default session option. Then restart GDM to get logged in to classic Gnome, switch to tty1 by pressing Ctrl + Alt + F1 and enter:


sudo service gdm restart

Logged in to classic Gnome now, go to Applications > Accessories > Terminal and rename your current xorg.conf in order to disable its use:


sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old

Note the capital 'X' for X11. The file might not be present in some systems. No problem if it gives an error like 'file not found'.

Now go to System > Administration > Additional Driver and if any drivers are enabled, remove them, reboot, re-install the drivers, reboot once more. Now logout from the classic Gnome session, at the login screen, click your username and Sessions menu should appear at the bottom of your screen. Choose 'Ubuntu' and login.