View Full Version : [SOLVED] Nvidia drivers, how do I get the proprietary to work?

June 9th, 2011, 11:18 PM

After using Arch Linux for a while, I tried Ubuntu 11.04 again. Most of it was a pleasant surprise, except for the nvidia drivers. I currently have the nouveau drivers, but when I activate the nvidia drivers and reboot, it's installed but not in use. I figured I should run nvidia-xconfig (as suggested by nvidia-settings) but that makes my computer boot into a tty. Removing the /etc/X11/xorg.conf file makes it boot in nouveau again.

How do I install the Nvidia drivers? Ive tried the drivers from nvidia.com too, with the same results. I really want to be able to play my games, and nouveau just isnt going to cut it.

Thanks in advance.

June 9th, 2011, 11:44 PM
Are drivers found if you run Additional Drivers? Can you activate the (recommended) one from there?

June 9th, 2011, 11:46 PM
dont use the drivers from nvidia.com, use the ones in the repos instead -- they are customized. Ensure that nvidia-current is installed and run

sudo nvidia-xconfig

and reboot

June 10th, 2011, 11:40 AM
Okay.. I installed it from the Additional Drivers dialog again, ran the sudo nvidia-xconfig, but I get the same results. Executing startx from tty1 gave me the following error:

(EE) No devices detected.

Fatal server error:
No screens detected

The Additional drivers dialog gives this state of the driver:
The driver is activated but currently not in use.

$ lsmod |grep nvidia
nvidia 9766978 0

I'm a bit confused, am I currently using the Nvidia driver or nouveau? I don't seem to the the right framerate in my games, so I guess I'm still at nouveau, but I do have 3d.. I'm clueless :(

edit: My games do not run, I don't know how I managed to get them running past though.

edit2: Oh I'm using an ASUS K73SV-TY081V laptop, maybe it's a sandy bridge problem or something? I have no idea how this should work..

June 11th, 2011, 02:19 PM

I'm now considering going arch linux on this laptop too if nobody knows how to fix it :(

June 11th, 2011, 02:40 PM
Which Nvidia card / chip are you using? There are two different Nvidia drivers (one for the newer chips and a "legacy" driver) and sometimes it can be tricky figuring out which one you need.

June 11th, 2011, 04:39 PM
I have a 540m.

June 11th, 2011, 05:20 PM
I have a 540m.

A quick Google search indicates that there is a problem with the current 11.04 kernel and your model of Nvidia chip. There is a newer kernel, however I doubt there is a compatible driver for it out yet. I Someone correct me if I'm wrong on this.

I would suggest either installing 10.10 or going with another distro for now.

June 11th, 2011, 07:24 PM
Okay, thanks your time everyone.

June 11th, 2011, 07:37 PM
Ah, I see. I couldn't understand what was wrong.
It seems you have been unlucky with that particular graphics chip. Keep checking for updates. Nvidia seem to be very good for updating drivers, on the whole :-)

June 12th, 2011, 11:27 AM
AHAAAAAAA (sorry, im quite happy)


For all those with sandy-bridge + nvidia card, go do that. It finally works, I have my nvidia card running as it should, at full speed! :D

Props to the devs out there <3