View Full Version : [SOLVED] Ubuntu does not detect the presence of cdROM

June 8th, 2011, 07:07 AM
Dear Ubuntu Users,

I have just had my Ubuntu 10.04.2 Luci installed under my Windows OS. Things seem to be fine until I find out next that my copy of Ubuntu does not detect the presence of the cdROM which installed the software itself on my desktop machine.

I have tried searching high and low for clue in this forum, tried all the recommended tricks to find out at last that there is no cdROM listed under my DISK UTILITY and when I input the following comman,

sudo lshw -class disk -class storage I only happened to see my hard drive and some USD drives being listed.

Also, Brasero Disc Burner does not detect the presence of a cd/ DVD rom devices.

Appreciate if someone can kindly assist me.
Many thanks in advance.


June 8th, 2011, 07:22 AM
There was a thread about a similar problem yesterday or the day before. If I recall, it was a driver problem with a SATA3 controller and when the poster hooked his DVD drive into a SATA 2.0 port things were fine.

1) Is this a CD or DVD drive?
2) Is it a SATA or IDE connection?

June 10th, 2011, 02:49 PM
Your suggestion indeed works! Fantastic. Thank you very much.