View Full Version : [ubuntu] ... on my ThinkPad L520; installation freezes

June 7th, 2011, 04:13 PM
Hi! First post, first linux installaion (just so you know what you are getting into ;) ). Also I am not shure this doesn't belong in Hardware & Laptops... wether it does is part of the problem I suppose.. What I am trying to do is install ubuntu-11.04-desktop-amd64.iso on my ThingPad L520. Relevant hardwarespecs here: http://www.abload.de/image.php?img=thinkpadfsbs.jpg
Problem is that whatever option I choose in the initial install dialog after booting the iso... it either shows a black screen (had it running for about 5 minutes... no change) or it runs through several lines of text and then stops at bio: create slab <bio-0> at 0. The images are correctly downloaded and I am using a USB stick on which I wrote the iso using a windows program called unetbootin.
I tried the ubuntu-11.04-alternate-amd64.iso aswell, no change. Fyi ... the same thing happened with several other distros I tried, the only thing I was able to install so far was a netinstall of Fedora 15.
So yea... truthfully I have no clue what I am doing here.. but I do want to learn it. So .. any suggestions? Searching here and Google were not helpfull so far.. I will continue to read though some threads here but I'd appreciate some help.

June 7th, 2011, 06:30 PM
Hi and welcome to the forums :-)

According to the specifications you have hyper-threading capability. Is it enabled in BIOS?

I think you should also check this link and try some options as the USB is booting:

For example, try acpi=off

Let us know if this helps you get further.

June 7th, 2011, 06:49 PM
Well thank you very much, that seems to have fixed it. I am installing right now.

Edit: Well ... I guess that would have been to easy. Installation went fine, now booting the os doesn't really work. "Ubuntu, with Linux 2.6.38-8-generic" gives me a black screen with a cursor in the top left corner, the rescuemode freezes at "bio: create slab <bio-0> at 0". I'll try to do some of the stuff suggested here: http://ubuntuforums.org/showthread.php?t=1743535

Edit2: Oh and Hyper-Threading seems to be enabled.

June 7th, 2011, 07:20 PM
Ok, by doing this
linux /boot/vmlinuz-2.6.38-8-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro nosplash --verbose text acpi=off
I can boot into a text console. From what I read in the thread you linked using acpi=off is kind of a last resort. So... what is actually wrong? Any way to find that out?

June 7th, 2011, 07:39 PM
Okay, instead of acpi=off try using i915.modeset=1

Follow the instructions from the link with boot options and see the section on how to set options temporarily once installed.

June 7th, 2011, 07:52 PM
linux /boot/vmlinuz-2.6.38-8-generic root=UUID=32939def-1f4a-4134-9b56-bed2319a9216 ro nosplash --verbose text i915modeset=1

Stops at "bio: create slab <bio-0> at 0". Using acpi=off I was able to start the gui. Everything seemed to work...

June 7th, 2011, 08:03 PM
i915modeset=1Is this just a typo? It should be

And I am running out of ideas. You may indeed need to ask this in Hardware & Laptops.

June 7th, 2011, 08:13 PM
Yea... afraid so. That was a typo. Also I checked the Intel site and unless I am understanding this totally wrong ... I don't see any connection between the i5 2520M and that chipset. It says the i915 is used for Centrino cores. Well... I guess I'll link this thread over to Hardware&Laptops. Thanks for your help so far!

Edit: adding Noapic and nolapic to the boot line makes the bootscreen look funny but does allow the gui to be loaded.. that ring any bells?

June 7th, 2011, 09:26 PM
I wish I could offer something more, just don't know what.

It surely has to be something basic and I sense you are getting close.

Perhaps check settings in BIOS like AHCI compatibility mode?

June 8th, 2011, 02:46 PM
Yea dont't worry, I'll ask over in the other forum. I tried AHCI compatibility mode but the os still wouldn't launch without the extra commands in the boot line. Again, thanks for your help. :)

June 8th, 2011, 02:49 PM
Sure, you are welcome.

Sorry I wasn't able to offer more :(

July 6th, 2011, 12:26 PM
I have the same problem on my new ThinkPad L520, although mine is an i7 model.

Did you ever find a solution?

I found a question on AskUbuntu (http://askubuntu.com/questions/41847/constant-freezes-on-new-sandy-bridge-thinkpad) which mentioned setting this in GRUB config:


But I don't have a clue how to do that via the installers before it's actually installed.