View Full Version : [ubuntu] Can't display at 1440x900 Ubuntu 11.04

June 6th, 2011, 07:22 PM
I have a computer which dual boots with Windows XP and Ubuntu 11.04 32 bit edition. The Ubuntu installation was a clean install.

I have a 512Mb nvidia 8500GT graphics card and have just bought a second hand Yuraku MA9JBA 19" monitor. The maximum resolution for this monitor is 1440x900 at 60Hz.

When running in Windows I was able to create this resolution in the nvidia control panel and display everything fine.

In Ubuntu, the nvidia X Server Settings decides that the screen is 1024x768, showing the model as CRT-1 (CRT-1 on GPU-0). The resolution defaults to "Auto" but it does give me the options to increase the resolution to "1152x864" and "1360x768" but none of these are suitable.

The output of my sudo gedit /etc/X11/xorg.conf is:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 270.29 (buildd@roseapple) Fri Feb 25 14:43:24 UTC 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"

Section "Files"

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"

# HorizSync source: builtin, VertRefresh source: builtin
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 28.0 - 55.0
VertRefresh 43.0 - 72.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8500 GT"

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select @1400x900 +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24

Following on from some suggestions on other posts and from searches I tried entering the line

Modes "1440x900"

In the "SubSection" are underneath "Depth" but this made no difference at all.

Any help would be greatly appreciated.

Many thanks.