View Full Version : [SOLVED] 11.04 Post Upgrade Reboot Issues Fixed

June 5th, 2011, 04:24 PM
I have seen many posts about problems with the 11.04 upgrade. I had two, one major and one minor but both were easy fixes once I knew the answers. After the upgrade all I had after rebooting was the GRUB prompt. I found all of this elsewhere on the web:

1) Create a bootable Ubuntu 11.04 CD or USB stick. I got the CD image and instructions from the Ubuntu site. I didn't do this before my upgrade and had to boot into Windows to make mine.

2) Boot from the CD or USB stick.

3) Once booted choose "Try Ubuntu".

4) After Ubuntu is running from the CD, open a terminal window and do the following:

sudo fdisk -l (That's a lower case "L" not a one)

(Look for the Linux partition with the asterisk under the "Boot" column. In my case it is sdc1. Yours may be different. I think sda1 is common for the first hard drive. Now mount the partition)

sudo mount /dev/sdc1 /mnt (Note replace the sdc1 with your Linux boot partition)

(Install GRUB2)

sudo grub-install --root-directory=/mnt /dev/sdc (Note that this is the drive sdc and not the partition sdc1)

(Unmount the drive)

sudo umount /dev/sdc1

(Reboot from the hard drive and not the CD)

sudo reboot

5) Hopefully GRUB is working properly and you'll see the GRUB menu. I tried the default kernel which ends in "pae" (2.6.38-8-generic-pae) and my computer would not boot. It would start to boot and then hang.

6) Reboot (probably the computer reset button)

7) At the Grub menu scroll to the "Previous..." option and then choose one of the available kernels. I used 2.6.38-8-generic.

(My computer booted this time with no problems. I had wireless networking care of ndiswrapper as I did with version 10. In fact everything worked).

8) Open a terminal window and do the following:

sudo apt-get install linux-headers-generic-pae

9) Reboot when finished.

10) After this reboot I chose 2.6.38-8-generic-pae and everything booted as expected.

11) Open a termnial window and update GRUB just to make sure:

sudo update-grub

Good luck!!!