View Full Version : [SOLVED] can't record from line-in

June 3rd, 2011, 12:06 AM
I run Kubuntu 11.04 and I have a C-Media CM8738 sound card. My problem is, my card won't record from the line-in jack, even when I set it to capture in alsamixer. Furthermore, the mic jack only records when both the line-in and the mic are set to capture in alsamixer. I'm using the same settings I used in 10.04, and the line-in captured fine then. I have no idea what the problem is, I've been searching around and I can't find anything about it. Thanks in advance.

June 3rd, 2011, 01:34 AM
Hm. Kubuntu uses the PulseAudio sound server nowadays; I think it's simply not routing the sound input to your recording application.

Start by installing the PulseAudio volume control tool pavucontrol (apt://pavucontrol) unless already installed, and start it.

Go to the Input Devices tab and pick Line-in in the Ports dropdown menu at your soundcard's device entry. Make sure it's not muted and that it's set to be the Fallback device.
Now go to the Recording tab and find the program you're trying to record with in that list. It may need to be trying to record to show up, depending on how good its pulse integration is. Make sure its dropdown menu has your soundcard selected and is not muted.
Now try again.

In parallel to this, make sure to try toggling which device is recording in alsamixer. I think setting an input to "not recording" in alsamixer stops PulseAudio from being able to tap into its stream.

June 3rd, 2011, 05:22 AM
I followed those steps, and now it's not recording from line-in or mic, although I can get it recording mic again through alsamixer.

June 22nd, 2011, 07:17 PM
Bump. Still can't find anything about this at all ... have tried a bunch of things and none of them have helped. Hopefully somebody knows how to fix this.

June 22nd, 2011, 08:31 PM
This might be a silly question, but can you record through usb? Is the software recording at all?

June 26th, 2011, 07:05 AM
I don't have any USB recording hardware, so no I can't. But I can record from my mic port so the recording software is working, I just can't do it from my Line-In port.

July 3rd, 2011, 04:25 AM
Well ... I fixed it by switching to OpenSUSE :-|
Ciao, Ubuntu forum. It's been fun.