PDA

View Full Version : PHP and GD help!



noob_Lance
May 16th, 2006, 05:40 AM
Hey, im looking to compile the GD library with PHP for a script im working on... but i have no clue how to do this... can someone please help me.. thanks:)

~Lance

hagen00
May 16th, 2006, 07:57 AM
I believe it's as easy as


apt-get install php4-gd
or

apt-get install php5-gd

Maybe restart apache after that.

noob_Lance
May 16th, 2006, 04:25 PM
ahahahah thanks :p i didnt kno it was in the repo's :p

hagen00
May 16th, 2006, 09:01 PM
it's a pleasure...and mate, this is Ubuntu, absolutely everything is in the repos! Isn't it great?!

noob_Lance
May 16th, 2006, 11:09 PM
do you know how to make a deb package to install and modify some little things in other programs :p because i have a program i would like to be in the repos lol :P

hagen00
May 17th, 2006, 12:20 PM
No, but google does
http://ftp.sun.ac.za/ftp/pub/documentation/building_packages/AT8047723203.html

Ahriman
May 24th, 2006, 09:45 AM
What about calendar support? Normally, I compile PHP with --enable-calendar , but I cannot see this module in the repos. Any clues as to how to add it into the installed PHp without removing the current install and manually compiling it?

Kvark
May 24th, 2006, 11:45 AM
According to Synaptic both php 4 and 5 have calendar support and a whole lot of other stuff compiled in. From the description of libapache2-mod-php5:

Compiled in extensions include: bcmath, bz2, calendar, ctype, dba, dbx, exif, filepro, ftp, gettext, iconv, mbstring, mime_magic, openssl, overload, pcre, posix, session, shmop, sockets, standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xml, xmlrpc, yp, zip, and zlib.