PDA

View Full Version : [ubuntu] Sound works, but not built-in mic for the Aspire One 532h-2588



vangbe
May 29th, 2011, 07:25 AM
I have already installed my sound card.
__________________________________________________ __

aplay -l


**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272X Analog [ALC272X Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0

Followed through this:

sudo gedit /etc/modprobe.d/alsa-base.conf


and added

options snd-hda-intel model=auto position_fix=0

__________________________________________________ __

After all of this, the built-in mic still doesn't work.
I'm using a Aspire One 532h-2588 laptop. Please I need to get this working so I can use VOIP. If anybody is curious what I'm using. I'm using ZoIper.

vangbe
May 29th, 2011, 07:39 AM
Just incase somebody mentions it. I already tried alsamixer.

ChrisKu
May 30th, 2011, 03:59 PM
Had a similar problem although not with a build in mic. I also thought I had all my Alsamixer settings correct. I solved the problem as follows:
1. Started Ubuntu from a LIveCD
2. Checked the mic there (it worked)
3. Opened Alsamixer an made a note of all the settings
4. Rebooted to the installed Ubuntu Environment and set all Alsamixer setting to the settings copied from the LiveCD environment
For me this solved the issue.

vangbe
June 2nd, 2011, 09:17 PM
tried it and it still doesn't work

lidex
June 4th, 2011, 04:10 AM
Use the alsa-info-script to provide detailed information.
Run this command in a terminal:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
Choose the upload option and provide a link for the output.
[Terminal="Applications->Accessories->Terminal"]