PDA

View Full Version : [ubuntu] nvidia resolution (I know - AGAIN!)



dd1linux
May 29th, 2011, 01:25 AM
Hi all, I apologize in advance because I am sure that this question has already been answered, but I just can't find the proper thread. Anyway, I just upgraded to 11.04, installed the nvidia driver via the "additional drivers" app, and everything seems to work fine - graphics are smooth, the sidebar slides nicely, etc., but in nvidia-setttings the highest resolution I can get is 1360x768 (although 1024x768 looks better). However, I have always used 1680x1050 (I believe those are the correct numbers, somewhere around there anyway). Also, my xorg.conf shows just this:


Section "Device"
Identifier "Default Device"
Option "NoLogo" "True"
EndSection

When I run nvidia-xconfig, I get:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 270.41.06 (buildmeister@swio-display-x86-rhel47-07.nvidia.com) Mon Apr 18 15:15:12 PDT 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Which looks right, but only gives me something like 640x480. Any help would be greatly appreciated. I think putting a "Modes" section under monitor or screen sections would help, but I can't remember where to put it.

BicyclerBoy
May 29th, 2011, 01:54 AM
Modes etc by itself will not help as the video mode pool has to be validated against the monitor EDID.
I guess the Mode you would want to add is already built-in & rejected.

There has been lots of problems with 11.04 & nvidia...

You could post your /var/log/Xorg.0.log file as an attachment..

dd1linux
May 29th, 2011, 05:47 AM
I already reinstalled 10.10. I think I'll just stick with it til these problems are resolved. If I make a new partition in the next week, ill post that file. Thank you so much for your reply.

BicyclerBoy
May 29th, 2011, 07:02 AM
The problems started with 11.04 & seem to be on-going...
The jockey method (additional drivers) does not seem to work or install properly for everyone.

To avoid the jockey method:
IMO The best way to get your nvidia driver package is from
nvidia x-swat team ppa
or
xorg-edgers ppa
or
some mythtv ppa has nvidia package..