PDA

View Full Version : [ubuntu] Nvidia GeForce 8200 driver problems on Ubuntu 11.04?



jxcheng
May 28th, 2011, 09:00 PM
I recently installed Ubuntu 11.04 on my Emachine Er1402-05, Wireless works fine, but not the grahics Emachine Er1402-05 has a nVidia GeForce 8200 graphics card.

The problem is that after installation it only support resolution upto 1024x768, while my LCD has native resolution at 1600x900.

I have installed the most recent nvidia driver
$sudo apt-get install nvidia-current

However, I was not able to config it:
$ sudo nvidia-xconfig
sudo: nvidia-xconfig: command not found

I was not able to install the package.
$ sudo apt-get install nvidia-xconfig
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nvidia-xconfig

Here is relevant info:

$ lspci | grep VGA
02:00.0 VGA compatible controller: nVidia Corporation C77 [GeForce 8200] (rev a2)


Here is the content of my xorg.conf.

$ cat /etc/X11/xorg.conf

Section "Device"
Identifier "Default Device"
Option "NoLogo" "True"
EndSection


Any help would be appreciated.

Regards,
Jim

BicyclerBoy
May 29th, 2011, 01:17 AM
The nvidia-xconfig is part of the nvidia driver package.
It should be installed into /usr/bin/..
I have never directly used nvidia-xconfig in >2 yrs of nvidia & HTPC.

Have you rebooted/restarted the X server after nvidia install ?
Can you run nvidia-settings (after reboot) ?
Can you select your required screen resolution/video mode ?

glxinfo
vdpauinfo

Post your
/var/log/Xorg.0.log file as an attachment..

jxcheng
May 29th, 2011, 01:51 AM
Have you rebooted/restarted the X server after nvidia install ?
Yes.

Can you run nvidia-settings (after reboot) ?
Yes. But it gives the warning message: "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."
However, I am not able to install and run nvidia-xconfig
$ sudo nvidia-xconfig
sudo: nvidia-xconfig: command not found

Can you select your required screen resolution/video mode ?
Nope. The highest availbe is 1024x768, while my LCD is 1600x900

Thanks

BicyclerBoy
May 29th, 2011, 02:06 AM
where is the /var/log/Xorg.0.log file......

So the nvidia X server can not start..

Run this in terminal
dmesg | grep nouveau

Have a search in dmesg output for anything to do with video VGA etc...

jxcheng
May 30th, 2011, 05:12 AM
The following command returns empty:
$ dmesg | grep nouveau

Now I am able to tun the nvidia-xconfig command:
$ sudo nvidia-xconfig
Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Default Device" must have a Driver line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

Here is the content of the configuration file:
$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 270.41.06 (buildmeister@swio-display-x86-rhel47-07.nvidia.com) Mon Apr 18 15:15:12 PDT 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

The problem is that I am still stuck with 1024x768 resolution.

wojox
May 30th, 2011, 05:34 AM
Try:


gksudo nvidia-settings

jxcheng
May 30th, 2011, 05:51 AM
I have tried nvidia-settings. However, in the configuration panel, the drop down list of resolution does not go to 1600x900. It does not recognize my LCD monitor correctly, and the max resolution only goes to 1360x768.

jxcheng
May 30th, 2011, 06:01 AM
After I changed the resolution to 1360x768 in nvidia-settings, things gets even worse.
After rebooting, the resolution is changed to 640x480, and I can not go any resolution higher than that.

Regards,
Jim

BicyclerBoy
May 30th, 2011, 06:56 AM
Please post the file /var/log/Xorg.0.log (as attachment)....

Your video card is not new so any old driver should fine..
You could try using an old driver version like 175.xx.xx..

jxcheng
May 30th, 2011, 07:18 AM
Attached is /var/log/Xorg.0.log .

How do I revert to an older driver version like 175.xx.xx. ?

In the "Additional Drivers" panel, I only see two choices: version 173 and current version for nvidia card.
I am using the current version.

jxcheng
May 30th, 2011, 07:23 AM
re-attach the log.
CHange the name to txt to avoid uploading error

BicyclerBoy
May 30th, 2011, 09:22 AM
Long shot...
Can you edit your grub cmdline options to remove

vt.handoff=7

You can do this as a temporary change in the initial boot-up grup phase...
vt.handoff=7 is meant to cause boot screen to switch to gui console screen 7 instead of all the scrolling text.

The data in the Xorg.0.log shows that you should be able add to change the resolution..

Can you connect your monitor by DVI cable & not by VGA..& then reboot & post the /var/log/Xorg.0.log file ?

You did try
gksudo nvidia-settings

change resolution & save it into xorg.conf.

jxcheng
May 30th, 2011, 04:55 PM
I am new to ubuntu.
How to remove vt.handoff=7 in grub?

I do not see such option in the file:
$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

jxcheng
May 30th, 2011, 05:50 PM
Thanks for all the help.

I switched to a DVI cable (actually HDMI to DVI) and the problem is solved.
Now it recognise all resolutions up to my LCD's native resolution 1600x900.


Regards,
Jim

BicyclerBoy
May 31st, 2011, 11:02 AM
That's good...

Hope this will help other's with the similar EDID problems..