View Full Version : Compiz alt+tab problem

Fabled One
May 18th, 2011, 11:21 AM
With 3D desktop cube enabled, alt-tabbing is broken. I can switch between windows, but I can no longer use that window. For example, I can't scroll or click any links in a browser.

Using Ubuntu 11.04 with GNOME.

Fabled One
May 20th, 2011, 07:26 PM
I got this working:
I initially had "Application Switcher" active which had the problem.
Now, I turned that off and enabled "Static Application Switcher".

Alt-tabbing now works properly with compiz enabled (although I don't know the difference between the two types of switchers.)

Copper Bezel
May 21st, 2011, 12:15 AM
Weird - I've seen another related bug like this, although it had to do with Alt+Tabbing to minimized windows. Did you prefer the ordinary Application Switcher, or is the Static Switcher an acceptable workaround?

Fabled One
May 21st, 2011, 12:23 AM
The Static Switcher is perfectly acceptable for me.

(But like I said, I don't know what the Application Switcher has to offer over the static one, so I don't know what I'm missing out on, if anything)

Edit: I just found the difference from this website: http://maketecheasier.com/compiz-windows-management-tool/2010/07/15/

Both are nearly identical, the main difference being that App Switcher will fade out background windows while switching, whereas Static will remove them entirely and only show the selected window. The screenshot above is using Static.

Copper Bezel
May 21st, 2011, 01:02 AM
That, and the Static Switcher also shows previews for all open windows instead of just three at a time. I actually switched between them for a while myself, because I wanted the Static Switcher's overview but kind of needed the smooth transitions of the Application Switcher. I gave up and switched back to the Ring. = )

I'll keep in mind, then, that the Application Switcher might have some problems in Natty. Thanks for the tip. = ) Technically, though, this isn't solved, because we don't know what's causing the problem with that particular plugin.

Fabled One
May 21st, 2011, 01:09 AM
Yup, you're right. Thread has been un-solved

June 23rd, 2011, 09:53 PM
Same problem here... the same problem happens when unfolding the cube..