View Full Version : [ubuntu] wireless causes freeze on 11.04 64 bit

May 17th, 2011, 02:22 AM
I upgraded to 64 bit ubuntu 11.04 on my Toshiba Satellite laptop. The laptop has a built-in Atheros AR5008x chipset wireless card, and I am running the ath9x drivers. Whenever I would enable wireless, my computer would freeze within a few minutes.

I thought it might have been an issue with the upgrade, so I did a clean install of 64 bit 11.04. The same thing has been occurring since the clean install. I can run a wired connection with no problems, but within a few minutes of connecting wireless, it freezes.

I've searched for a solution to no avail. One bug report suggested I upgrade to kernel 2.6.38-02063805-generic. I did this with no problems, and I ran it using wireless for a couple hours last night with no freezes. But today, it's freezing all over again.

I dual boot Windows Vista (ugh) on this laptop, and I have no issues with the wireless there, so I know its not a hardware issue. Any help would be greatly appreciated!

July 14th, 2011, 03:44 AM
i know the feeling. i had the same problem on 32-bit Natty on a Toshiba Satellite C650D. i think (think!) i have fixed it with an upgrade to 2.6.38-11, see details at http://ubuntuforums.org/showthread.php?p=11045204&posted=1#post11045204

hope it works for you!