View Full Version : [other] wubi, windows 7, and ubuntu 9.4

May 13th, 2011, 10:44 PM
alrighty, long story short, I screwed up. I had installed a copy of ubuntu 9.1 to my sda1 partition and a copy of windows 7 to sda2 and it worked pretty well, but after needing to change the partitions around, I deleted sda1 and did a wubi install. I forgot to adjust the mbr before deleting the ubuntu install and my live CD is still running ubuntu 9.1 (think that's grub 1.5) and I can't update the live CD, as my only functioning OS is currently running off it. I suspect, therefore, that the mbr is still pointing to a now non-existant partition to find the boot files.

So, in short, how do I use my current live CD to allow me to boot into windows in this situation?

my current partition table is sda2: windows 7/wubi, sda1: media/backups

May 14th, 2011, 03:45 AM
sudo apt-get install lilo
sudo lilo -M /dev/sda mbr
Note: you'll get a panel after the first command with a big warning - just ignore that as it relates to using lilo for booting linux.

That will replace the bootloader. Or you can insert a windows DVD, boot to a repair prompt, and run: bootrec /fixmbr

PS if you like you can post the results of the bootinfoscript (http://bootinfoscript.sourceforge.net/) so we can confirm what is going on. But the windows bootloader is what you need if you now just have Windows + wubi

May 15th, 2011, 08:46 PM
Alright, that seems to have fixed it. Thanks for the advice ^.^