View Full Version : [SOLVED] Can't get flash work in Natty 64 Bit

May 13th, 2011, 09:24 AM
During the past days, I've tried "everything" to get flash working in my fresh Natty 64 Bits install to my Acer Aspire 5745G -laptop. I've read countless of hours through the forums, but none of the tips have helped in my case. Using the latest Firefox and Chromium.

For example, I've downloaded the 64 Bits "libflashplayer.so" from Adobe:

...and put it into:
sudo cp libflashplayer.so /usr/lib64/mozilla/plugins

...and restarted the browsers, even the entire PC, but still flash doesn't work.

What an I doing wrong? ...help very much appreciated!

May 13th, 2011, 05:42 PM
Have you tried FlashAid? https://addons.mozilla.org/en-US/firefox/addon/flash-aid/

May 13th, 2011, 07:58 PM
Thanks for the tip, I'd try FlashAid but unfortunately not success (even the test script jammed and never finished)


I did the following, helped at least in my case:

1.) Uninstalled Flash Plugin Installer from Ubuntu Software Center. Also, make sure you don't have flash option selected in "Restricted Extras" (Ubuntu Software Center)
2.) Downloaded Flash for 64 Bits (flashplayer10_2_p3_64bit_linux_111710.tar.gz) from:
3.) Extracted file: "libflashplayer.so" from the file above
4.) Deleted older versions/traces to "libflashplayer.so" from directory:

5.) Copied the "libflashplayer.so" to the plugins directory:

sudo cp libflashplayer.so /usr/lib64/mozilla/plugins
6.) Restarted my PC
7.) Flash is working!

Hope this helps others, too

August 1st, 2011, 05:45 PM
Thanks, Abilnet - this worked well and I have Flash back on my machine.:D

August 11th, 2011, 08:10 PM
hp pavilion dev9607us
1 gig ram
nvidia 7150m graphic card

installed natty with wubi and had the same flash issue. installed flash aid in ff and bingo flash is NOW working perfectly. thanks for the help.:)