View Full Version : IRAF on Ubuntu 11.04 amd64 (64 bits)

May 12th, 2011, 11:57 PM
Hello everybody!

Recently I have installed the IRAF 2.15.1a on my Ubuntu 11.04 amd64 (64 bits). But I got some problems running specific tasks from STSDAS 3.13 (so far, only x86).

So, I tried to install the IRAF 2.14 version and I could not install. That's because "libc5" of Ubuntu is not working for IRAF.

So I would like to know if someone already has managed to install the IRAF 2.14 on Ubuntu 11.04 amd64.

Thank you,

May 13th, 2011, 02:47 PM
I have an installer for IRAF. It works on 32 and 64 bits.
It includes

IRAF 2.14.1
PyRAF 1.9
DS9 6.2
Telarchive 1.6.1
FV 5.3

You can download the .iso from

May 13th, 2011, 07:29 PM
Hi favilac,

Are you sure that works on 64 bits version of ubuntu 11.04?
Because for me its not working...


June 6th, 2011, 11:40 PM
Hello, I have the same problem and am trying to solve it for some time now without any success

June 7th, 2011, 05:09 AM
... if you put the error you are getting it will be much easier to help.

June 11th, 2011, 09:04 AM
I'm extremely new to Ubuntu and linux altogether and I wont lie, I have very little understanding atm linux wise. Much more of a hardware person at the moment. Hopefully that's all soon to change. None the less one of the reasons for me switching to ubuntu is for my degree, I find myself beginning to use IRAF myself and I tried installing through this ISO and here is the errors it thrown my way. Now it could very well be my fault but here we are:

dpkg: warning: overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
(Reading database ... 145548 files and directories currently installed.)
Preparing to replace ldso:i386 1.9.11-15 (using deb/ldso_1.9.11-15_i386.deb) ...
Unpacking replacement ldso:i386 ...
dpkg: dependency problems prevent configuration of ldso:i386:
ldso:i386 depends on libc6 (>= 2.1.94).
dpkg: error processing ldso:i386 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:

if it's something stupid on my part please feel free to let me know because what better way to learn what exactly I am doing.

June 11th, 2011, 01:10 PM
Hi dreamsfear,
On ubuntu 11.04 until now you have two options to run IRAF:
1) 32bits version of ubuntu, so you can use the ISO you mentioned
2) 64bits version of ubuntu, with IRAF 2.15.1a from iraf.net

The ISO will not work at 64bits!

June 11th, 2011, 04:38 PM
It works in 64 bits, and has been working for over 3 years since I started (Ubuntu 8.04).

Now, this problem in particular is weird.

It's complaining that libc6 is not installed, but the installer pulls libc6-dev as a dependency which in turn should pull libc6 and is not doing it.

Try doing a "apt-get install libc6" before running the installer and let me know what happens.

One final note, research workstations usually run the same software for years. In this case, the script is developed in Ubuntu LTS which is supported for three years. I strongly recomend for this reason and others to stay in LTS versions for work that depends on consistency.

June 11th, 2011, 04:59 PM
I have got the same problem. Does any one have a solution for it???

June 12th, 2011, 05:06 AM
After reading up a bit on ubuntu I decided to just do a clean install of the 32 bit version. After reading all the problems I just felt it would be the smarter move in all honesty but I'm gonna give this another shot so heres to hoping.

August 14th, 2011, 12:25 PM
I also get the same error as above on 64-bit Ubuntu 11.04.

For what it's worth to anyone else trying to install this, I managed to get IRAF to install by editing the 'install.sh' file within the above .iso file.

Place a '#' at the start of the two lines that start 'dpkg -i ... ldso...' and 'dpkg -i ... libc5...' on lines 37/38 or 47/48 depending on your architecture (32-bit/64-bit respectively).

This will allow the script to successfully install IRAF, although probably breaking a few things along the way. All I want to use IRAF for is the ellipse routine however, and I can confirm this works, so I'm happy. Using this .iso for IRAF install is still a lot easier than trying to follow the joke install instructions on the IRAF website!

Good luck!

August 24th, 2011, 04:47 AM
I suggest reading these notes regarding 64-bit IRAF (v2.15) :)


August 29th, 2011, 04:09 AM

It has the new STSCI_IRAF with TABLES 3.14, STSDAS 3.14 and STECF.

The new version now supports Ubuntu 11.04 AMD 64 (the previous bug has been fixed and several symlinks corrected, as far as I can tell).

To install you must run first the uninstall script included in this version, because the packages ldso, libc5 and termcap_compat are not needed anymore (thanks IraGainesUK for the insight!).

The installer in the same place as always:


Test away!!

October 10th, 2011, 06:49 PM
Just so people know,the ISO works for my Ubuntu 11.04(64bits).I dont know why exactly people are saying its not.

November 29th, 2011, 10:12 AM

Thanks for the installer! Everything works fine! And perhaps add a MSCRED package in IRAF. If you add in the installer ESO-MIDAS and IDL, it would be a great alternative Scisoft, but only for Ubuntu. It would be great!!!!!!

November 30th, 2011, 06:45 PM
>add a MSCRED package in IRAF.

>If you add in the installer ESO-MIDAS
Haven't used MIDAS, so for the moment have no idea how feasible is this.

>and IDL
IDL is a propietary system, and needs a license from the company to run. Therefore, it's not legally possible to include it.

Also, the new version I have uploaded now, doesn't need the iraf user. For this reason you must run the uninstall-previous.sh script to delete the previous version and iraf user before you can install the new one.

December 1st, 2011, 10:43 PM

Excellent! Now I can do data processing and science:guitar:, instead of the "Kama Sutra with Linux programm installation" :)

Thank you very much! What you are doing is really important!

February 2nd, 2012, 06:25 AM
I have no problem running the install script, but get Ioads of "unmet dependencies" errors. Anyone else with similar issues or know what they are indicative of?

Thanks in advance for your help!

February 4th, 2012, 02:32 AM

Have you done an "apt-get update" first?
Are the universe and multiverse repos enabled?

February 20th, 2012, 11:30 PM
I haven't used it myself, but there is also PyRAF, a python implementation of IRAF. For those of you who know some python it may be easier to install/run.


February 21st, 2012, 02:49 AM
PyRAF is an extension shell to IRAF, so you need IRAF installed first.

PyRAF is an alternate shell to the standard ECL that IRAF uses.
Also, it has pyhton bindings so you can include IRAF routines in your python code.

July 2nd, 2012, 04:03 PM
A new version of SAO DS9 :p: