View Full Version : [all variants] 11.04 NFS server issue with Win2K8R2 client

May 12th, 2011, 07:58 PM
I have three Linux systems running nfs-kernel-server (Ubuntu 9.04, CentOS 5.6, and Ubuntu 11.04) and a Windows 2K8R2 system with the Microsoft NFS client installed.

My NFS tests are running well against the 9.04 and CentOS systems but are failing against 11.04.

Everything I have thought to look at regarding configuration on the servers is the same. These are the specific issues when running against the 11.04 box from snooping the wire:

Client issues a MOUNT request for /_testNFS1 which succeeds and returns a file handle.

Client issues a GETATTR request using the returned handle.

Against the 9.04 and CentOS boxes GETATTR succeeds and the client continues processing.

Against the 11.04 box, there is no reply to the GETATTR. It does not get a failure reply -- no reply at all. The client then retransmits the GETATTR request which is again ignored. The client then tries/retransmits FSSTAT and FSINFO requests using the same handle and then gives up issuing a UMNT. The Windows client reports the error "The semaphore timeout period has expired."

I have double-checked permissions on the 11.04 box, tried disabling NFSv4, tried different r/w size options on the client all to no avail. rpcinfo, showmount, exportfs dumps for all 3 servers show the same information.

I *can* mount the 11.04 /_testNFS1 directory from the Ubuntu 9.04 client.

Also, there does not seem to be any other network issues between the 11.04 box and Win client.

Any directions on how to debug this further and resolve it? Obviously want to use the latest Ubuntu going forward...

Thank you.

May 12th, 2011, 09:16 PM
On servers, I recommend sticking with LTS releases, not necessarily the newest.

With that said, have you tried samba? I didn't think Windows handled NFS very well at all, even with the client services installed... I know that's not the answer you're looking for, but might be a workaround in the short-term.