View Full Version : [ubuntu] Ubuntu 10. LAMP---PHP file not executed and offered as a download

May 11th, 2011, 02:24 PM

PHP file is not being executed,it is offered as a download.I installed LAMP as

apt-get install apache2
apt-get install php5
apt-get install mysql-server

I have tried everything like
sudo a2enmod php5
Module php5 already enabled

even re-installing libapache2-mod-php5

sudo apt-get purge libapache2-mod-php5

sudo apt-get install libapache2-mod-php5

I am using public_html directory and it is working fine.MySQL is working perfect and i can access it from the Terminal.

My computer Hard disk is faulty and i had sent it for a repair.I am using Ubuntu 10.10 as Live CD and installing lamp on it and intent to save the source php files on an external hard-disk.

I have tried the ApachePHPMySQL ubuntu documentation and whole lot of online resource.Nothing works.Any Idea will be appreciated.

Thanks in Advance

May 25th, 2011, 04:15 PM
I have the same issue. I installed Virtualmin on a ubuntu server 10 LTS.
When I execute phpinfo.php file it gives me


You don't have permission to access /phpinfo.php on this server.

I put a HTML file & thats working fine.

I can see the php5 mod is already enabled on my server.

So where is problem?

Many Thanks

May 26th, 2011, 12:01 PM
Looks this forum is dead????