PDA

View Full Version : [lubuntu] Natty broke my hostapd



emunson
May 4th, 2011, 02:40 PM
I use an Atheros AR922X wireless card in my router/access point and everything was working fine under maverick. Now when I try and start hostapd I get this:




root@puffin:~# hostapd -d /etc/hostapd/hostapd.conf
Configuration file: /etc/hostapd/hostapd.conf
ctrl_inerface_group=0
Failed to create interface mon.wlan0.
nl80211 driver initialization failed.
wlan0: Unable to setup interface.
rmdir[ctrl_interface]: No such file or directory


Google is not helping, the only relevant hit is a thread where the poster fixed the problem but did not say how.

emunson
May 5th, 2011, 02:01 PM
Bump

Cheesehead
May 5th, 2011, 02:30 PM
Is the nl80211 driver included with the update? Or do you need to install it separately?

Is the driver installed...is it showing in /sys/modules?

emunson
May 5th, 2011, 04:04 PM
I don't think that is a kernel driver, it was part of the hostapd binary in maverick.

emunson
May 6th, 2011, 03:41 AM
Bump

emunson
May 6th, 2011, 08:16 PM
bump

Cheesehead
May 7th, 2011, 02:45 AM
Stop bumping.
It's not helping because you are not providing enough information.

If you believe that your wi-fi hardware driver does not need to be updated, then why do you think you are getting an error message that tells you that your wi-fi hardware driver needs to be updated?

Have you looked in syslog or (hint, hint) dmesg for additional information?


---------------------------

EDIT:

Wow.
Upon reflection, that was very inappropriate of me to write.
And a very mean way to express it.
This post was not helpful at all.

My apologies.

emunson
May 7th, 2011, 03:50 AM
I bump because in my experience with the ubuntu fora, if your post isn't on the first page, it isn't being read and certainly isn't being answered. Also, this isn't the way I would approach someone asking for help, generally if I need more information I ask for it, I certainly don't ignore the post and then get snarky about not providing enough info. </rant>

The error posted above is all I get from the system. dmesg/syslog show that everything is great from the kernel perspective. If I am reading the docs correctly, the nl80211 driver is part of the hostapd package and is the interface to all mac80211 based wireless drivers in kernel. It is the upgrade that broke my setup, I am running the latest out of the Natty repo.

emunson
May 8th, 2011, 09:02 PM
Bump

paoletto
July 12th, 2011, 10:32 PM
same problem here

bump!

emunson
July 12th, 2011, 11:30 PM
paoletto:

I am not sure what fixed it, but I no longer have this problem.

emunson
July 13th, 2011, 03:51 PM
Part of what has changed is I no longer start hostapd on boot, it is started by my br0 script. Not sure if that mad the difference, but you might try starting hostapd by hand and see if it comes up.