PDA

View Full Version : What's up with compiz performance these days?



Dustin2128
May 4th, 2011, 11:41 AM
Back when I first installed linux, I had a 128MB Ti4800. Compiz ran beautifully well, even with a compliment of only 1GB DDR and a P4. Today, I can't have two cubes (one for each monitor) without a severe performance drop- on the magnitude of around 10fps. Additionally, my 256MB GeForce 6200 could barley run compiz at all, despite having higher clocks, memory, and bandwidth than the Ti4800. So can anyone tell me why my old card with a quarter of the memory and I-don't-even-want-to-know less power runs compiz slowly on my computer with a GeForce 9600? Not isolated to compiz either- kwin also ran horribly on the 6200- comparable to the performance on a machine with an intel chipset that's now my server!

frankbooth
May 4th, 2011, 11:58 AM
From my own experiences, Linux runs smoother with older hardware than new hardware. But this might not be the reason for your performance issues *shrug*

pt123
May 4th, 2011, 12:20 PM
Compiz since 10.04 has be come sluggish for me, I am running an onboard nvdia chip from 3 years.

NightwishFan
May 4th, 2011, 12:35 PM
Runs well with my integrated Intel. I believe Compiz was recently rewritten though, so it might perhaps just have some bugs to squash.

Dustin2128
May 4th, 2011, 09:12 PM
Runs well with my integrated Intel. I believe Compiz was recently rewritten though, so it might perhaps just have some bugs to squash.
That may be it- it was either the original compiz or compiz fusion when it was on the P4- it was before renaming fusion I know.