View Full Version : [SOLVED] WiFi : Atheros AR5B93

Dr. Quack
May 2nd, 2011, 06:09 PM

My computer was, until recently, running windows 7. It crashed at the beginning of the weekend, and I decided to switch to ubuntu.

Everything seems to be working fine apart from the wireless card.

My computer is an Acer Aspire 5251-1513, and my wireless card is an Atheros AR5B93.

I've already searched and tried multiple solutions in the forums, and none of them seem to work for me. Maybe I'm not doing something right?

Thanks for your reply!

May 2nd, 2011, 06:57 PM
I had some trouble with my Atheros card as well. Have u tried installing wicd? Run "sudo stop network-manager" and run wicd...

Dr. Quack
May 3rd, 2011, 05:47 PM
Hi again!

I found a solution that seems to be working so far in this thread: http://ubuntuforums.org/showthread.php?t=1744892

First off, I entered this and came up with two different things, one was acer_wmi:

sudo rfkill list
The result was that I had a 'Soft block' by acer_wmi. I tried to unblock it with this command:

Sudo rfkill unblock all
After that had no effect, I tried what the forum the forum post (link above) said I should do, and it totally worked:

sudo rmmod acer_wmi

I really hope this works for anyone else who might have this problem!

Dr. Quack

Dr. Quack
May 4th, 2011, 02:10 AM
Unfortunately, this solution is only temporary. The command needs to be executed a EACH BOOT.

I created a new thread to try and solve this problem (since I am but a humble noob end user):


May 4th, 2011, 02:49 AM
What happens when you install Wicd and remove Network Manager?

Do the problems persist?