PDA

View Full Version : [ubuntu] 11.04 Startup and Shutdown screens do not display properly



billio
May 2nd, 2011, 11:29 AM
The startup and shutdown displays are a series of vertical black and white lines, and the text displayed on them appears as more or less white blobs.

Otherwise, the displays when 11.04 is running are fine, but this startup looks so naff it would be nice to change it so that the diplays can be read. I would hate to demonstrate Ubuntu to someone and have to explain such a display.

Nvidia Driver Version 173.14.30
Monitor Philips 107X2

Logan7x3
May 2nd, 2011, 11:37 AM
I have this "problem" as well. Actually, most people do! This is just a bug that Most linux distributions have not worked out. as far as i know, there is nothing you can do about it, but i can assure you that this will not harm your system in any way.

Hope that this helps!

billio
May 2nd, 2011, 12:03 PM
This feature was not a part of 10.10 !.

techbeam
May 3rd, 2011, 02:59 PM
Few days ago,I upgraded to Natty and got this issue

White screen with black stripes appears momentarily after choosing Ubuntu from Grub screen.

Then it goes to login and boots to Desktop and works fine.

Similar issue(white screen with black stripes) occurs while shutdown.

Graphics Card: ATI Radeon 5750

Dmesg log @ http://viewer.zoho.com/docs/ismdbb

Dpkg log @ http://viewer.zoho.com/docs/rtMacg

Xorg log @ http://viewer.zoho.com/docs/zuk9b

Please help.

oferfrid
May 6th, 2011, 09:01 AM
I have the same thing (only after installing 11.04 and not in the 10.10) the problem is also in the console at Cltr+Alt+1...

SilFox
May 8th, 2011, 01:02 AM
After installing Ubuntu 11.04 (new install) Desktop is working perfect (nvidia driver installed).
The startup and shutdown displays are a series of vertical black and white lines, and the text displayed on them appears as more or less white blobs.
On computer startup, (when pressing <Shift> to display GRUB2 menu since Ubuntu is only OS on that computer, so by default menu is not shown) there are two entries (btw, memory test entry is disabled):

Ubuntu, with Linux 2.6.38 -8-generic
Ubuntu, with Linux 2.6.38 -8-generic (recovery mode)

When system is booted, and I go to terminal ( CTRL+F1 to F6), TTY1 - 6 are messed, I mean letters are displayed something like white boxes, - unreadable.

Same thing happens when I choose GRUB2 menu entry "recovery mode" - screen turns to white and black stripes, and after 10 seconds, there is white menu box, but with unreadable fonts, sometime like hieroglyphes. (btw,GRUB2 Menu at startup is OK).

I uncommented line
<GRUB_TERMINAL=console>
in /etc/default/grub, (sudo update-grub after that, and reboot) and then all is OK, but I don't want loose graphical menu.
So I commented that back and tryed to set line <GRUB_GFXMODE=1920x1200>
(sudo update-grub after that, and reboot) but no luck.

Then I tryed, at startup, or reboot, to edit GRUB2, by selecting menu entry and pressing <e> :

setparams 'Ubuntu, with Linux 2.6.38 -8-generic

recordfail
set gfxpayload=$linux_gfx_mode
ismod part_msdos
insmod ext2
set root='(/dev/sda,msdos1)'
search --no-floppy --fs-uuid --set=root 37a70fb8-8e4d-47a6-b8fe-d534f192e349
linux /boot/vmlinuz-2.6.38-8-generic root=UUID=37a70fb8-8e4d-47a6-b8fe-d534f192e349 ro quiet splash vt.handoff=7
initrd /boot/initrd.img-2.6.38-8-generic
When I edit entry line to tihis:

set gfxpayload=1920x1200
Than, when Ubuntu is booted, I have normal TTY1 - 6 !

Also, when I edit and make same change at second GRUB2 entry (recovery mode), mean edit
<set gfxpayload=$linux_gfx_mode> to <set gfxpayload=1920x1200>, and boot into recovery mode - everything is OK, letters are readable as they should be.
Of course, after rebooting, changes are restored to defaults.

So I looked around how to make that changes permanent, and after seeing this link (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/685611), it gives me idea to add this line to /etc/default/grub :

GRUB_GFXPAYLOAD_LINUX=1920x1200
(sudo update-grub after that, and reboot)
and now TTY1 - 6 under full system boot works, and also recovery mode works OK, and no more white and black vertical lines at shutdown/startup screen.

Of course, 1920x1200 is native resolution of my SyncMaster245Bplus monitor, so you need to set that value according to your own monitor.

I hope this can help someone.

MAFoElffen
May 8th, 2011, 01:21 AM
After installing Ubuntu 11.04 (new install) Desktop is working perfect (nvidia driver installed).
The startup and shutdown displays are a series of vertical black and white lines, and the text displayed on them appears as more or less white blobs.
On computer startup, (when pressing <Shift> to display GRUB2 menu since Ubuntu is only OS on that computer, so by default menu is not shown) there are two entries (btw, memory test entry is disabled):

Ubuntu, with Linux 2.6.38 -8-generic
Ubuntu, with Linux 2.6.38 -8-generic (recovery mode)

When system is booted, and I go to terminal ( CTRL+F1 to F6), TTY1 - 6 are messed, I mean letters are displayed something like white boxes, - unreadable.

Same thing happens when I choose GRUB2 menu entry "recovery mode" - screen turns to white and black stripes, and after 10 seconds, there is white menu box, but with unreadable fonts, sometime like hieroglyphes. (btw,GRUB2 Menu at startup is OK).

I uncommented line
<GRUB_TERMINAL=console>
in /etc/default/grub, (sudo update-grub after that, and reboot) and then all is OK, but I don't want loose graphical menu.
So I commented that back and tryed to set line <GRUB_GFXMODE=1920x1200>
(sudo update-grub after that, and reboot) but no luck.

Then I tryed, at startup, or reboot, to edit GRUB2, by selecting menu entry and pressing <e> :

setparams 'Ubuntu, with Linux 2.6.38 -8-generic

recordfail
set gfxpayload=$linux_gfx_mode
ismod part_msdos
insmod ext2
set root='(/dev/sda,msdos1)'
search --no-floppy --fs-uuid --set=root 37a70fb8-8e4d-47a6-b8fe-d534f192e349
linux /boot/vmlinuz-2.6.38-8-generic root=UUID=37a70fb8-8e4d-47a6-b8fe-d534f192e349 ro quiet splash vt.handoff=7
initrd /boot/initrd.img-2.6.38-8-genericWhen I edit entry line to tihis:

set gfxpayload=1920x1200than, when Ubuntu is booted, I have normal TTY1 - 6

Also, when I edit and make same change at second GRUB2 entry (recovery mode), mean edit
<set gfxpayload=$linux_gfx_mode> to <set gfxpayload=1920x1200>, and boot into recovery mode - everything is OK, letters are readable as they should be.
Of course, after rebooting, changes are restored to defaults.

So I looked around how to make that changes permanent, and after seeing this link (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/685611), it gives me idea to add this line to /etc/default/grub :

GRUB_GFXPAYLOAD_LINUX=1920x1200and now TTY1 - 6 under full system boot works, and also recovery mode works OK, and no more white and black vertical lines at shutdown/startup screen.

I hope this can help someone.
Agreed, except that that... well look at this sticky:
http://ubuntuforums.org/showthread.php?t=1743535

The variable
$linux_gfx_mode is set from /etc/grub.d/00_header, the line that says "set gfxmode=auto" > change to "set gfxmode-1920x1200" and then add/append vga-xxx (where xxx is the mode you want, that specs the HEIGTHxWIDTHxDEPTH) to the kernel boot line in /etc/default/grub that says: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=771"...
--OR--
You could change "set gfxmode-1920x1200" to "set gfxmode-1920x1200x24" (the full parms are HEIGTHxWIDTHxDEPTH) to pick up the "DEPTH" parameter, WHICH is why most of these KMS lockups are now occuring. All the info, diagnostics and current workarounds are in the sticky linked above,

SilFox
May 8th, 2011, 02:19 AM
Originally Posted by MAFoElffen
Agreed, except that that... well look at this sticky:
http://ubuntuforums.org/showthread.php?t=1743535

The variable
$linux_gfx_mode is set from /etc/grub.d/00_header, the line that says "set gfxmode=auto" > change to "set gfxmode-1920x1200" and then add/append vga-xxx (where xxx is the mode you want, that specs the HEIGTHxWIDTHxDEPTH) to the kernel boot line in /etc/default/grub that says: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=771"...
--OR--
You could change "set gfxmode-1920x1200" to "set gfxmode-1920x1200x24" (the full parms are HEIGTHxWIDTHxDEPTH) to pick up the "DEPTH" parameter, WHICH is why most of these KMS lockups are now occuring. All the info, diagnostics and current workarounds are in the sticky linked above

Thank You for this link and informations (if only I had that yesterday, it could save me a lot of time!)
I saw file 00_header , but I simply did not have enough knowledge to change anything there.

n6vig
March 27th, 2012, 05:08 AM
I'm having the same problems described in this old thread.

Black & white vertical lines, fonts seem to be mirrored images or not visible at all.

The set gfxmode= setting was no help at all.

Thankfully, the GRUB_GFXPAYLOAD_LINUX setting worked for me.

Thank you for your post, SilFox.

picture of problem attached (date in camera is wrong):
http://webpages.charter.net/aalto/PICT0689a.jpg