View Full Version : [ubuntu] Disabled Unity in compizconfig, now menu bar is gone

May 2nd, 2011, 10:34 AM
I have Ubuntu 11.04. I wanted to disable Unity in CompizConfig, thinking it would revert to the menu style from previous versions of Ubuntu, but now the menu bars are gone and I can't do anything. I can only see the desktop and the files on it.

Does anyone know how to fix this? :confused:

May 2nd, 2011, 10:47 AM
Select the 'Ubuntu Classic' option at the login screen. That should load the old Gnome2 interface + compiz.

May 2nd, 2011, 10:55 AM
I have no login screen, it goes straight to the desktop. I can't turn that option on either.

May 2nd, 2011, 11:00 AM
Hit ctrl+alt+f1, that should drop you to the console login prompt. Login, then type:

sudo service gdm restart

...that should bring you back to the login screen.

May 2nd, 2011, 11:18 AM
From a console terminal try unity --reset

May 2nd, 2011, 11:29 AM
Thanks guys, that fixed it

May 3rd, 2011, 12:18 PM
Hey yeah had same problem, was only able to get to this because i had a keyboard shortcut for loading firefox :-) the "unity --reset" seems to be working though it's still in the process of doing something i'm not quite sure..

Thankyou! :)

May 4th, 2011, 02:05 AM
How long should it take to do unity --reset?
I feel like its been running a long time for me and hasn't changed from "Setting Update
toggle_window_shaded_key" in awhile.